summaryrefslogtreecommitdiff
path: root/dev-python/trollius/trollius-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/trollius/trollius-2.2.ebuild')
-rw-r--r--dev-python/trollius/trollius-2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/trollius/trollius-2.2.ebuild b/dev-python/trollius/trollius-2.2.ebuild
new file mode 100644
index 000000000000..9de2fd0afd5d
--- /dev/null
+++ b/dev-python/trollius/trollius-2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Port of the asyncio project to Python 2.7 (deprecated)"
+HOMEPAGE="https://github.com/vstinner/trollius https://pypi.org/project/trollius/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" runtests.py -v 2 || die "Testing failed under ${EPYTHON}"
+}