summaryrefslogtreecommitdiff
path: root/dev-python/uvicorn/uvicorn-0.22.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uvicorn/uvicorn-0.22.0.ebuild')
-rw-r--r--dev-python/uvicorn/uvicorn-0.22.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/uvicorn/uvicorn-0.22.0.ebuild b/dev-python/uvicorn/uvicorn-0.22.0.ebuild
index a5836d8ffe40..2c2f842fe04d 100644
--- a/dev-python/uvicorn/uvicorn-0.22.0.ebuild
+++ b/dev-python/uvicorn/uvicorn-0.22.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 optfeature
@@ -67,6 +67,14 @@ python_test() {
tests/middleware/test_logging.py::test_running_log_using_fd
)
fi
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ tests/supervisors/test_signal.py::test_sigint_abort_req
+ # hang
+ tests/protocols/test_websocket.py::test_send_close_on_server_shutdown
+ )
+ fi
+
epytest
}