summaryrefslogtreecommitdiff
path: root/dev-python/zstandard/zstandard-0.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zstandard/zstandard-0.11.0.ebuild')
-rw-r--r--dev-python/zstandard/zstandard-0.11.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/zstandard/zstandard-0.11.0.ebuild b/dev-python/zstandard/zstandard-0.11.0.ebuild
new file mode 100644
index 000000000000..38d656c972ff
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.11.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/cffi:=[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"