summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_pytest
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cmake_pytest')
-rw-r--r--dev-ros/ament_cmake_pytest/Manifest6
-rw-r--r--dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.1.4.ebuild45
-rw-r--r--dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.3.0.ebuild45
-rw-r--r--dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild45
-rw-r--r--dev-ros/ament_cmake_pytest/metadata.xml11
5 files changed, 0 insertions, 152 deletions
diff --git a/dev-ros/ament_cmake_pytest/Manifest b/dev-ros/ament_cmake_pytest/Manifest
deleted file mode 100644
index f7d6eeefedc9..000000000000
--- a/dev-ros/ament_cmake_pytest/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-DIST ament_cmake-1.1.4.tar.gz 94117 BLAKE2B 612bf25301b9794cf51b460819cf4a029547fbc97f7a428215a19f0a7747115de02d3f2cb5f5e524e73ba30813388ca7bff059ab7fe472916eaf2b23ecc76355 SHA512 56acd3d2a8d4b15a164dfdcaa2157fff2889a4c5c0b155ad65a815760f531cdf10226d158f40fc15660c52dd1585b85a2566e402f31881378351624f286efb3d
-DIST ament_cmake-1.3.0.tar.gz 103040 BLAKE2B 8220d380923a591667b3b4bbe785f30ac935ce10c4fd6bf8bd22149586373f353cd9e71723638dca503bd54ff709783ea1e133c5034901fe2d891fd6bbe7c560 SHA512 44f71102e22fe9f6cd8c3cc13960d63af377eec0a6f7fb7ae99c18f2afae07f3997c9f226f7db8cc8020acdf45561ad9eb1006c6834125d6da137e8638617df8
-EBUILD ament_cmake_pytest-1.1.4.ebuild 1135 BLAKE2B 77a1c6695e1443bcebd5d57a4e05f57168b6945d2297641fd22433d7b2ecef63ac3a2909911b521a1a0c05d3109a56fcbad62a36ca23ddb9b70f8ed552666e3c SHA512 bb1d0e5f54213736ff1aae52465bf80bb66a2f2ac5e4dae3d7bae7de3cdf40a5c5702fa019be59c4f8aa31d8eb77a2ffea566c658ab93d2761e27fd7d817ed3a
-EBUILD ament_cmake_pytest-1.3.0.ebuild 1135 BLAKE2B 77a1c6695e1443bcebd5d57a4e05f57168b6945d2297641fd22433d7b2ecef63ac3a2909911b521a1a0c05d3109a56fcbad62a36ca23ddb9b70f8ed552666e3c SHA512 bb1d0e5f54213736ff1aae52465bf80bb66a2f2ac5e4dae3d7bae7de3cdf40a5c5702fa019be59c4f8aa31d8eb77a2ffea566c658ab93d2761e27fd7d817ed3a
-EBUILD ament_cmake_pytest-9999.ebuild 1135 BLAKE2B 77a1c6695e1443bcebd5d57a4e05f57168b6945d2297641fd22433d7b2ecef63ac3a2909911b521a1a0c05d3109a56fcbad62a36ca23ddb9b70f8ed552666e3c SHA512 bb1d0e5f54213736ff1aae52465bf80bb66a2f2ac5e4dae3d7bae7de3cdf40a5c5702fa019be59c4f8aa31d8eb77a2ffea566c658ab93d2761e27fd7d817ed3a
-MISC metadata.xml 332 BLAKE2B 4cfb0cdd190fee00f82e219ca7ed55bcfcdf350b2a4abb5001133d0d577e95925c69b7e978aff53a9a9313f7bead35df2e325f878fde235ef28e3580c859b8b1 SHA512 09dca0eeafb32ae8219fa2b0a09b8fe6269ee620900f71ca5528879d961f1192d73584af07c9501a4b3a4c9ad9f2af2b0bd1a9bec0f4099cdc9dec7b177537aa
diff --git a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.1.4.ebuild b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.1.4.ebuild
deleted file mode 100644
index 755a786964a8..000000000000
--- a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.1.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-any-r1
-
-ROS_PN="ament_cmake"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to run Python tests using pytest in the ament buildsystem"
-HOMEPAGE="https://github.com/ament/ament_cmake"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- dev-ros/ament_cmake_core
-"
-DEPEND="${RDEPEND}"
-# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/ament_package[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]')
-"
-
-python_check_deps() {
- python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
- "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
-}
diff --git a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.3.0.ebuild b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.3.0.ebuild
deleted file mode 100644
index 755a786964a8..000000000000
--- a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-1.3.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-any-r1
-
-ROS_PN="ament_cmake"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to run Python tests using pytest in the ament buildsystem"
-HOMEPAGE="https://github.com/ament/ament_cmake"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- dev-ros/ament_cmake_core
-"
-DEPEND="${RDEPEND}"
-# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/ament_package[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]')
-"
-
-python_check_deps() {
- python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
- "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
-}
diff --git a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild b/dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild
deleted file mode 100644
index 755a786964a8..000000000000
--- a/dev-ros/ament_cmake_pytest/ament_cmake_pytest-9999.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-any-r1
-
-ROS_PN="ament_cmake"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to run Python tests using pytest in the ament buildsystem"
-HOMEPAGE="https://github.com/ament/ament_cmake"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- dev-ros/ament_cmake_core
-"
-DEPEND="${RDEPEND}"
-# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/ament_package[${PYTHON_USEDEP}]
- dev-python/catkin_pkg[${PYTHON_USEDEP}]')
-"
-
-python_check_deps() {
- python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
- "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
-}
diff --git a/dev-ros/ament_cmake_pytest/metadata.xml b/dev-ros/ament_cmake_pytest/metadata.xml
deleted file mode 100644
index 507777b6c9a3..000000000000
--- a/dev-ros/ament_cmake_pytest/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ament/ament_cmake</remote-id>
- </upstream>
-</pkgmetadata>