summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cppcheck
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_cppcheck')
-rw-r--r--dev-ros/ament_cppcheck/Manifest6
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild43
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.12.1.ebuild43
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild43
-rw-r--r--dev-ros/ament_cppcheck/metadata.xml11
5 files changed, 0 insertions, 146 deletions
diff --git a/dev-ros/ament_cppcheck/Manifest b/dev-ros/ament_cppcheck/Manifest
deleted file mode 100644
index 1f191ddad13a..000000000000
--- a/dev-ros/ament_cppcheck/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-DIST ament_lint-0.11.2.tar.gz 265435 BLAKE2B 09545bd029dc692e5393983a3fc9210600c4a6456635238b7038ff87799f9cfde9c2d3c7ceb4c01b71594ba7bd159e8b6b3c2370bdfcdbf3d6189a895b96292a SHA512 1a379f4fb0ead306a668aef2b9e390728d6d3901b75f43fac6ccc28681a8010e42b094237f3f1ab95ca304ba917c8fb5d5519ec0581cadb346e6eb05466e39f0
-DIST ament_lint-0.12.1.tar.gz 281555 BLAKE2B 1feabfc9e65b09970cb9d9706e9fbc3ca8b60d0592597a8a8666f3b272e71a09c28bf3f21926f0f3b96d93e61d3f8c99286b2b5658359116305bbaf449b40207 SHA512 34625c9ff0615c09dc5e918896af5f46480de735388e57c06c8d8f3267cd98c7e0314ddc99d8ba328dbfa949c51eb893121f6639689f3a803503c77164e56bcc
-EBUILD ament_cppcheck-0.11.2.ebuild 929 BLAKE2B b1b70c094bad20ba0c6147e1415713897f58d2e1a3b5b5160021824c636a07f5791b9ece887315231e5a6cc46b0c62b6cdb6e032d0565ab393bed0395636631f SHA512 d0e8d29ff2b81f9ce9d79d895362e90cdbd7630ac844546a05843d874190da8f23281abbeb2f767e7784c4e8fefdf9cddf8723a5b99b65a22757f8b2ca42cc2c
-EBUILD ament_cppcheck-0.12.1.ebuild 929 BLAKE2B b1b70c094bad20ba0c6147e1415713897f58d2e1a3b5b5160021824c636a07f5791b9ece887315231e5a6cc46b0c62b6cdb6e032d0565ab393bed0395636631f SHA512 d0e8d29ff2b81f9ce9d79d895362e90cdbd7630ac844546a05843d874190da8f23281abbeb2f767e7784c4e8fefdf9cddf8723a5b99b65a22757f8b2ca42cc2c
-EBUILD ament_cppcheck-9999.ebuild 929 BLAKE2B b1b70c094bad20ba0c6147e1415713897f58d2e1a3b5b5160021824c636a07f5791b9ece887315231e5a6cc46b0c62b6cdb6e032d0565ab393bed0395636631f SHA512 d0e8d29ff2b81f9ce9d79d895362e90cdbd7630ac844546a05843d874190da8f23281abbeb2f767e7784c4e8fefdf9cddf8723a5b99b65a22757f8b2ca42cc2c
-MISC metadata.xml 331 BLAKE2B ef826875ff734a0a5781b15d3db3ab6876ab5df6b2d3fa600009c0fe533b7d006b0dc61a5ad0b2760a09b3c1c8f7bd57cd5cb61c73a3ce1789fa426806bd712f SHA512 2b5b3a1e5621d206063d1d60c7b824479b20e786f48a857b13a7db789f6b9d590a55f6a17694b4ad20b6d6474c34ffa40d286d6a99bda08a3326b2ffcc41cec5
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild
deleted file mode 100644
index 7a2b556580d5..000000000000
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_9,3_10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to perform static code analysis on C/C++ code using Cppcheck"
-HOMEPAGE="https://github.com/ament/ament_lint"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-RDEPEND="
- dev-util/cppcheck
-"
-DEPEND=""
-BDEPEND=""
-
-# pytest.ini is there but no tests are ran causing it to fail
-RESTRICT="test"
-
-distutils_enable_tests pytest
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.12.1.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.12.1.ebuild
deleted file mode 100644
index 7a2b556580d5..000000000000
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.12.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_9,3_10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to perform static code analysis on C/C++ code using Cppcheck"
-HOMEPAGE="https://github.com/ament/ament_lint"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-RDEPEND="
- dev-util/cppcheck
-"
-DEPEND=""
-BDEPEND=""
-
-# pytest.ini is there but no tests are ran causing it to fail
-RESTRICT="test"
-
-distutils_enable_tests pytest
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild
deleted file mode 100644
index 7a2b556580d5..000000000000
--- a/dev-ros/ament_cppcheck/ament_cppcheck-9999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_9,3_10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to perform static code analysis on C/C++ code using Cppcheck"
-HOMEPAGE="https://github.com/ament/ament_lint"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-RDEPEND="
- dev-util/cppcheck
-"
-DEPEND=""
-BDEPEND=""
-
-# pytest.ini is there but no tests are ran causing it to fail
-RESTRICT="test"
-
-distutils_enable_tests pytest
diff --git a/dev-ros/ament_cppcheck/metadata.xml b/dev-ros/ament_cppcheck/metadata.xml
deleted file mode 100644
index e997622e1d3a..000000000000
--- a/dev-ros/ament_cppcheck/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ament/ament_lint</remote-id>
- </upstream>
-</pkgmetadata>