summaryrefslogtreecommitdiff
path: root/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/neovim-ruby-client/neovim-ruby-client-0.9.0.ebuild')
-rw-r--r--dev-ruby/neovim-ruby-client/neovim-ruby-client-0.9.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.9.0.ebuild b/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.9.0.ebuild
deleted file mode 100644
index 8bac82c5b68c..000000000000
--- a/dev-ruby/neovim-ruby-client/neovim-ruby-client-0.9.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_NAME="neovim"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_BINDIR="exe"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby bindings for Neovim"
-HOMEPAGE="https://github.com/alexgenco/neovim-ruby"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-RDEPEND+=" app-editors/neovim"
-DEPEND+=" test? ( app-editors/neovim )"
-
-ruby_add_rdepend "
- >=dev-ruby/msgpack-1.1:0
- =dev-ruby/multi_json-1*
-"
-
-all_ruby_prepare() {
- sed -i -e '/\(bundler\|pry\)/ s:^:#:' spec/helper.rb || die
-
- # Avoid tests that result in a unix socket path that is too long
- sed -i -e '/\(establishes an RPC connection\|sets appropriate client info\)/askip "socket path length"' spec/neovim_spec.rb || die
-}