summaryrefslogtreecommitdiff
path: root/dev-ruby/rdoc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/Manifest1
-rw-r--r--dev-ruby/rdoc/rdoc-6.6.3.1-r1.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-ruby/rdoc/Manifest b/dev-ruby/rdoc/Manifest
index 747a9289ecc2..bcee4ede7f30 100644
--- a/dev-ruby/rdoc/Manifest
+++ b/dev-ruby/rdoc/Manifest
@@ -3,5 +3,6 @@ DIST rdoc-6.6.2.tar.gz 765932 BLAKE2B 39bcb0f1af6ee4d53b9011179556d8f1a6b09e2071
DIST rdoc-6.6.3.1.tar.gz 766103 BLAKE2B 15cef9df763e40e105155d49c6c0c1a449c366ac35ab6036c43773c52114f00b19109b056033366b873b5b3317a3bf11c574dd76094d8f606fa0916a84257d0a SHA512 c6f3aae83e895e2de28e5a7c27456160dd53007ceb4464a045e0211473eb3d51f49a7c2ac28f2e44e807c5b36447140d15eadff65bfa52335e94adc9c8b56d2e
EBUILD rdoc-6.5.0.ebuild 2732 BLAKE2B 254a80d4442f1179852aaed6a98aa7ff488c1f87cc8c37ecde832f4954979091ea17b9b6e9bcc12fb649cb257803e58a5aed549e37664458be9c5672d5a41fc2 SHA512 1d5db6b03b09668ec089ca199cbe0a1b7ded3d7a1bd5e3abd40e2ce67381289f16e88d056eaf8ca2c5d446e714c066d98edc299a84f8bc68b705640ad04f86f6
EBUILD rdoc-6.6.2.ebuild 2733 BLAKE2B f859027cb05db8bbc6904bbe093f7c8be893986a7c1ea397db826f16957b964b16c67c2aab1ca0050b7e1832507dc8ecb999611d0abe0ec23a0bbaa0ae3e5482 SHA512 710cc66d453aa88622f1c0890bab5cd439c2c9ca2e95e868f3ff720bd77a2d3fed936d26d30062e671e3b268fcab743c09f9b6a500c5ea2fb01b8e9a7402a837
+EBUILD rdoc-6.6.3.1-r1.ebuild 2764 BLAKE2B 221368aa8add1b04cb086c2811c7f03c62bc5f96005a5427402c90356ef4612b4f6823111613ca974a87f99c1c20217dec9c1993837fa0ee8839d039a2502c63 SHA512 91440549233b209c21967d6169f39bab89db66b8069b64f00f612d1836d345db864c4d6e27f956548d0ca0b55586728a30349c8ea08c50a790f62cfcab17ae7c
EBUILD rdoc-6.6.3.1.ebuild 2728 BLAKE2B 0637c41220e793cab111fec6c2f906fe9df64fe4771fb363cb0bc69a8619211583be1f3cf90034807a2fead72266d06a858ffbbba40264bd776410e118e872a8 SHA512 466417f02fbfb5b6934a7ed7168b5d97f117777b176171a0975ae65f5f1f4174d972f467897ff2455f5d24633c87a93b6f7fc7cb6c46659b216193bb3bf4d605
MISC metadata.xml 336 BLAKE2B 142894745c624081f44dfccc6509273287120a43ceb8d7471634d92ab970bbc7747ce12b3a770b085c8c55a30f2c52ee34e0f27ba4be804ee2056150fb3b035f SHA512 438973812b1541e96ffd4add9422bd19e2c09f3f5b8ddc3ef86a670827c6bce9ed9c1bf9df0601927c959584b63a9d0986d0377807856ab8301fc8a8176922e1
diff --git a/dev-ruby/rdoc/rdoc-6.6.3.1-r1.ebuild b/dev-ruby/rdoc/rdoc-6.6.3.1-r1.ebuild
new file mode 100644
index 000000000000..e282ebb89a7e
--- /dev/null
+++ b/dev-ruby/rdoc/rdoc-6.6.3.1-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rdoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
+HOMEPAGE="https://github.com/ruby/rdoc/"
+SRC_URI="https://github.com/ruby/rdoc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby-BSD )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND+=">=app-eselect/eselect-ruby-20181225"
+
+ruby_add_rdepend "
+ >=dev-ruby/psych-4.0.0
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/kpeg-1.1.0-r1
+ >dev-ruby/racc-1.4.10
+ dev-ruby/rake
+ test? (
+ dev-ruby/bundler
+ >=dev-ruby/minitest-5.8:5
+ dev-ruby/test-unit-ruby-core
+ )"
+
+all_ruby_prepare() {
+ # Other packages also have use for a nonexistent directory, bug 321059
+ sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/rdoc/test_rdoc*.rb || die
+
+ # Avoid unneeded dependency on bundler, bug 603696
+ sed -i -e '/bundler/ s:^:#:' \
+ -e 's/Bundler::GemHelper.gemspec.full_name/"rdoc"/' \
+ -e '/rubocop\/rake/ s:^:#:' \
+ -e '/RuboCop/,/end/ s:^:#:' Rakefile || die
+
+ # Skip rubygems tests since the rubygems test case code is no longer installed by rubygems.
+ sed -i -e '/^task/ s/, :rubygems_test//' Rakefile || die
+
+ # Remove test that is depending on the locale, which we can't garantuee.
+ sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
+
+ # Remove test depending on FEATURES=userpriv, bug 361959
+ sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ ruby -S exe/rdoc --force-output || die
+ rm -f doc/js/*.gz || die
+ fi
+}
+
+each_ruby_compile() {
+ LANG=C.UTF-8 ${RUBY} -S rake generate || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for bin in rdoc ri; do
+ ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
+
+ for version in $(ruby_get_use_implementations); do
+ version=`echo ${version} | cut -c 5-`
+ if use ruby_targets_ruby${version}; then
+ ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
+ sed -i -e "1s/env ruby/ruby${version}/" \
+ "${ED}/usr/bin/${bin}${version}" || die
+ fi
+ done
+ done
+}
+
+pkg_postinst() {
+ if [[ ! -n $(readlink "${ROOT}"/usr/bin/rdoc) ]] ; then
+ eselect ruby set $(eselect --brief --colour=no ruby show | head -n1)
+ fi
+}