summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-glib2/ruby-glib2-3.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-3.5.1-r1.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-3.5.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-3.5.1-r1.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-3.5.1-r1.ebuild
new file mode 100644
index 000000000000..1789b42c0dae
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-3.5.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+RDEPEND+=" >=dev-libs/glib-2"
+DEPEND+=" >=dev-libs/glib-2"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5.1-glib-2.76.patch
+)
+
+all_ruby_prepare() {
+ ruby-ng-gnome2_all_ruby_prepare
+
+ # Skip spawn tests since our sandbox also provides items in the
+ # environment and this makes the test fragile.
+ rm -v test/test-spawn.rb || die
+}