summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild')
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild
deleted file mode 100644
index 9988c947a842..000000000000
--- a/dev-ruby/ruby-oci8/ruby-oci8-2.1.8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-inherit multilib ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-DESCRIPTION="A Ruby library for Oracle OCI8"
-HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-RDEPEND+=" dev-db/oracle-instantclient-basic"
-DEPEND+=" dev-db/oracle-instantclient-basic"
-
-EXT_DIR="ext/oci8"
-
-each_ruby_configure() {
- # configure the native libraries
- ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
-}
-
-each_ruby_compile() {
- # compile the native libraries
- emake -C ${EXT_DIR} V=1 || die "could not compile native library"
-}
-
-each_ruby_install() {
- # install the native libraries
- emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
- # install the gem files
- each_fakegem_install
-}