summaryrefslogtreecommitdiff
path: root/dev-ruby/syntax/syntax-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/syntax/syntax-1.2.1.ebuild')
-rw-r--r--dev-ruby/syntax/syntax-1.2.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-ruby/syntax/syntax-1.2.1.ebuild b/dev-ruby/syntax/syntax-1.2.1.ebuild
deleted file mode 100644
index 41f4003b936c..000000000000
--- a/dev-ruby/syntax/syntax-1.2.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Syntax highlighting for sourcecode and HTML"
-HOMEPAGE="https://github.com/dblock/syntax"
-SRC_URI="https://github.com/dblock/syntax/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test doc"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare() {
- # Remove manual doc since it can not longer be build and it blocks default rdoc recipe.
- rm -rf doc || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib test/ALL-TESTS.rb || die
-}