summaryrefslogtreecommitdiff
path: root/dev-ruby/thor
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/Manifest5
-rw-r--r--dev-ruby/thor/metadata.xml18
-rw-r--r--dev-ruby/thor/thor-0.19.4.ebuild41
-rw-r--r--dev-ruby/thor/thor-0.20.0.ebuild58
4 files changed, 0 insertions, 122 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
deleted file mode 100644
index f50f56e3db17..000000000000
--- a/dev-ruby/thor/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST thor-git-0.19.4.tgz 88733 BLAKE2B 8be54310cc4bf4a0308e6b103832831b89285003bb22a679986cd02636aaee57a25aa606f3e99bf532961a4e1d3625c46bfdb874a09f66cab85a21e5f7ed22d6 SHA512 a5cc52b23806e6104b12f924324960f2567bcd6c73b72ad47c33da222201b0377e7677b996698774de8adf3eff551926393785323ecf46cb59d72eb0e5b05aa0
-DIST thor-git-0.20.0.tgz 91758 BLAKE2B 86e4079a86a9c65852e710e40e49e915afe5522512f061ecc62aed48acc08a5397cc82d45cff7c4b1dd549ec57d8699b9afe7c391ac9ab838d1ba9100f1f058a SHA512 aa5344c94cad7c33dd0582409dbcf9bd109bf97b37131357a4cc8a66317acf8781460e8fe5532b301a74521010be59bb34ac1c68bc01ad3140bfe73fedc2a451
-EBUILD thor-0.19.4.ebuild 1155 BLAKE2B db1b5e8f9f73f8638aea3ead1a1cc7e754a829c8be39d8179aa5a7b9af1ce50349191bff14e2a8c52d0f3e54e64cd60d7eb486c55b6316f951e4660c3f7826e9 SHA512 74b73fbce42e3fc78572b5d9723fdeb6d00fea7544583540bce034265ce27744c4cfa86b346331d1db051c6858a420afcac5ca027ed9d4fc987d7e9a424c47b6
-EBUILD thor-0.20.0.ebuild 1437 BLAKE2B 2402abd3eb5b17bbd577f0a77df7d95b51a38e023555b0f39136cc9e3d3a0e53b80ba375a3851c4ffd037d5341f1d6606583c7339429a436df2c140ca9b6d990 SHA512 90e2e05922022ed356d7c81812cfadef0ec1fff1f0f9680edf9c039d33cdebc44128f31408df83e1eee7cd1696cfa267ec239bfd9dd0941dd16d7daeb299fda6
-MISC metadata.xml 680 BLAKE2B d4b03ac058de229b055e01ee99da7745a8fc67200979f626b55d6156d573269bb260c42ef44d6dd3b391a3e06d46844ef3fcd7cdd1f0d4053957c00bcfb1fd27 SHA512 d4938ad6ec003fe17d09274f39a2526c84d69d447b1e8063e9301000b776496fb3f8fd6d7e596791d9f8d05714e856d6a6d8df2c5c4747420e3221edf48ab264
diff --git a/dev-ruby/thor/metadata.xml b/dev-ruby/thor/metadata.xml
deleted file mode 100644
index 5a3ee8ed7504..000000000000
--- a/dev-ruby/thor/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <longdescription>
- Thor is a simple and efficient tool for building self-documenting
- command line utilities. It removes the pain of parsing command line
- options, writing "USAGE:" banners, and can also be used as an
- alternative to the Rake build tool. The syntax is Rake-like, so it
- should be familiar to most Rake users.
- </longdescription>
- <upstream>
- <remote-id type="github">erikhuda/thor</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/thor/thor-0.19.4.ebuild b/dev-ruby/thor/thor-0.19.4.ebuild
deleted file mode 100644
index f548e71b984e..000000000000
--- a/dev-ruby/thor/thor-0.19.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="none"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="doc"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}
diff --git a/dev-ruby/thor/thor-0.20.0.ebuild b/dev-ruby/thor/thor-0.20.0.ebuild
deleted file mode 100644
index 60e9b5f02184..000000000000
--- a/dev-ruby/thor/thor-0.20.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="doc"
-
-USE_RUBY="ruby22 ruby23 ruby24" ruby_add_bdepend "
- test? (
- dev-ruby/childlabor
- dev-ruby/webmock
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby25)
- einfo "Skipping tests due to circular dependencies"
- ;;
- *)
- RSPEC_VERSION=3 ruby-ng_rspec spec || die
- ;;
- esac
-}