summaryrefslogtreecommitdiff
path: root/dev-tex/xmltex/xmltex-1.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/xmltex/xmltex-1.9-r2.ebuild')
-rw-r--r--dev-tex/xmltex/xmltex-1.9-r2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-tex/xmltex/xmltex-1.9-r2.ebuild b/dev-tex/xmltex/xmltex-1.9-r2.ebuild
index 0f52e2b027dd..6ae39aebfbc3 100644
--- a/dev-tex/xmltex/xmltex-1.9-r2.ebuild
+++ b/dev-tex/xmltex/xmltex-1.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,7 +26,10 @@ RDEPEND="${DEPEND}
!=dev-texlive/texlive-htmlxml-2007*"
src_compile() {
- TEXMFHOME="${S}" fmtutil --cnffile "${FILESDIR}/format.${PN}.cnf" --fmtdir "${S}/texmf-var/web2c" --all\
+ fmt_call="$(has_version '>=app-text/texlive-core-2019' \
+ && echo "fmtutil-user" || echo "fmtutil")"
+
+ TEXMFHOME="${S}" $fmt_call --cnffile "${FILESDIR}/format.${PN}.cnf" --fmtdir "${S}/texmf-var/web2c" --all\
|| die "failed to build format ${PN}"
}