summaryrefslogtreecommitdiff
path: root/dev-util/astyle
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest4
-rw-r--r--dev-util/astyle/astyle-3.0.1-r1.ebuild89
-rw-r--r--dev-util/astyle/astyle-3.1-r2.ebuild21
3 files changed, 6 insertions, 108 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
index 1500706d12b4..6038ec7a3420 100644
--- a/dev-util/astyle/Manifest
+++ b/dev-util/astyle/Manifest
@@ -1,5 +1,3 @@
-DIST astyle_3.0.1_linux.tar.gz 172483 BLAKE2B 4c80491cbcc976aa38ff294014df0dc01b39685eafdac6989bea082b1f61120c3985d14ff6db9f76606bbe8da1aaa344c2e0c9c2999a014f5d54384c0420cf97 SHA512 3e8d617c0ec89682bfb076081bb63ae9d44e897de0c85d5109b28adbbfe0620d5dacf59a4bd96ac30a5a4fcb3be136758e9c6fe2c69258b37956c212890a7158
DIST astyle_3.1_linux.tar.gz 185589 BLAKE2B d0bc9bf3403de89d207f33ac885c7cd57fd1e71314c947e1593ee24ade9ce36c83c6fd8e7021f44d8d3b344ea3add63fa5a7b246c40f10193dc38b51e7ad36bc SHA512 2e8f13d291abda66bbba30174c364c81a81a490e0a21376f7da7cf471644c22caa37b9eefb100d093bf26d1a8bfa9d2f14b4c2a9b75b3cb84428b4514e277ff2
-EBUILD astyle-3.0.1-r1.ebuild 2387 BLAKE2B a91a68c3161f8938a3c2be1f005d03e54d10755043b6c0aa69cec1af145136ef90fa388f37acd6aa625252b55d205cb52fba1d9cee4d7452a37ae7f480d00b65 SHA512 9865738112a2ff3c012f09da2cd8b73b13a9f981d1242eeb60e14b6fa4ae783961b0807a1fb56638415b5f0cb593a306a4958dab46115924dcb1d5179b8380a1
-EBUILD astyle-3.1-r2.ebuild 2394 BLAKE2B a43d343d01a3a67181552ef4ee270567e8d56ebe28057a2e95c69f7e67364334ac4e289c48d2b9a95c80d3eeed31f098f2996a480d68f2f12232cbbab5100dda SHA512 060a9a0f576df46da55553d2cfd7c1b08bf78c870ce791a611b88c3a50f283183f688c45fcb3ce23e9062bdc143e0bf9f430d40ad64e498d0244499df66734c9
+EBUILD astyle-3.1-r2.ebuild 1891 BLAKE2B fea27eafaf14eaf1245a87a873dbfa327a23987468a291a9bf8de1af50d57f168143ae94b6dfb8dadfdf121ee3fc13f6efd90656962bd866093e27c2477544be SHA512 ecab4c77e646ee8dd2f174e50e8b5c3af9a077b1c1ddfac4ab05ec56e1b83e82ff7f8053d3f52454c282a9f545a470ba2caa2f1786956a26514b6f0adb988fe7
MISC metadata.xml 754 BLAKE2B c034556afe246a6d75d57b2e37399bdd24a37046a1bf0181757ed449f144f099964e7cdf470502f83542707094c752de3841d92bf2844fa7ee0b6038d25494f2 SHA512 0e4087bab09255528dfce61e21b12a4a05b93d3eaf75874b2a2b12f168046c0e9e040c29321766cfd505bdc5360eb6d16d320a73b317849d19b2555a95415396
diff --git a/dev-util/astyle/astyle-3.0.1-r1.ebuild b/dev-util/astyle/astyle-3.0.1-r1.ebuild
deleted file mode 100644
index 7396f1662f61..000000000000
--- a/dev-util/astyle/astyle-3.0.1-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs versionator java-pkg-opt-2
-
-DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
-HOMEPAGE="http://astyle.sourceforge.net/"
-SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/3.0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="examples java static-libs"
-
-DEPEND="app-arch/xz-utils
- java? ( >=virtual/jdk-1.6:= )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- if use java ; then
- java-pkg-opt-2_src_prepare
- sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
- -e "s:ar crs:$(tc-getAR) crs:" \
- -i build/gcc/Makefile || die
- else
- default
- fi
-}
-
-src_configure() {
- append-cxxflags -std=c++11
- tc-export CXX
- default
-}
-
-src_compile() {
- # ../build/clang/Makefile is identical except for CXX line.
- emake CXX="$(tc-getCXX)" -f ../build/gcc/Makefile -C src \
- ${PN} \
- shared \
- $(usev java) \
- $(usex static-libs static '')
-}
-
-src_install() {
- doheader src/${PN}.h
-
- pushd src/bin >/dev/null || die
- dobin ${PN}
-
- local libastylename="lib${PN}.so.${PV}"
- local libastylejname="lib${PN}j.so.${PV}"
- local libdestdir="${EPREFIX}/usr/$(get_libdir)"
-
- dolib.so "${libastylename}"
- dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(get_major_version)"
- dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
- if use java ; then
- dolib.so "${libastylejname}"
- dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(get_major_version)"
- dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
- fi
- if use static-libs ; then
- dolib.a lib${PN}.a
- fi
- popd >/dev/null || die
- if use examples ; then
- docinto examples
- dodoc -r file/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- local HTML_DOCS=( doc/. )
- einstalldocs
-}
-
-pkg_postinst() {
- if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
- elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
- elog "for modern use. Some options that were valid in 2.06 or older are now"
- elog "deprecated. For more information, consult astyle's release notes at"
- elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
- elog
- elog "${EROOT%/}/usr/share/doc/${P}/html"
- fi
-}
diff --git a/dev-util/astyle/astyle-3.1-r2.ebuild b/dev-util/astyle/astyle-3.1-r2.ebuild
index 7f30eabb7a36..82c533c6d7d1 100644
--- a/dev-util/astyle/astyle-3.1-r2.ebuild
+++ b/dev-util/astyle/astyle-3.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit flag-o-matic toolchain-funcs versionator java-pkg-opt-2
+inherit flag-o-matic toolchain-funcs java-pkg-opt-2
DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
HOMEPAGE="http://astyle.sourceforge.net/"
@@ -57,11 +57,11 @@ src_install() {
local libdestdir="/usr/$(get_libdir)"
dolib.so "${libastylename}"
- dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(get_major_version)"
+ dosym "${libastylename}" "${libdestdir}/lib${PN}.so.$(ver_cut 1)"
dosym "${libastylename}" "${libdestdir}/lib${PN}.so"
if use java ; then
dolib.so "${libastylejname}"
- dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(get_major_version)"
+ dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so.$(ver_cut 1)"
dosym "${libastylejname}" "${libdestdir}/lib${PN}j.so"
fi
if use static-libs ; then
@@ -76,14 +76,3 @@ src_install() {
local HTML_DOCS=( doc/. )
einstalldocs
}
-
-pkg_postinst() {
- if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
- elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
- elog "for modern use. Some options that were valid in 2.06 or older are now"
- elog "deprecated. For more information, consult astyle's release notes at"
- elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
- elog
- elog "${EROOT%/}/usr/share/doc/${P}/html"
- fi
-}