summaryrefslogtreecommitdiff
path: root/dev-util/bpftool/bpftool-6.6.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bpftool/bpftool-6.6.8.ebuild')
-rw-r--r--dev-util/bpftool/bpftool-6.6.8.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-util/bpftool/bpftool-6.6.8.ebuild b/dev-util/bpftool/bpftool-6.6.8.ebuild
index 8d18340895fc..6bccebe1c3cf 100644
--- a/dev-util/bpftool/bpftool-6.6.8.ebuild
+++ b/dev-util/bpftool/bpftool-6.6.8.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit estack linux-info optfeature python-any-r1 bash-completion-r1 toolchain-funcs
MY_PV="${PV/_/-}"
@@ -88,6 +88,9 @@ src_prepare() {
# dev-python/docutils installs rst2man.py, not rst2man
sed -i -e 's/rst2man/rst2man.py/g' Documentation/Makefile || die
+
+ # remove -Werror (bug 887981)
+ sed -i -e 's/\-Werror//g' ../../lib/bpf/Makefile || die
}
bpftool_make() {