summaryrefslogtreecommitdiff
path: root/dev-util/chroot-wrapper/chroot-wrapper-0.9.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/chroot-wrapper/chroot-wrapper-0.9.8.ebuild')
-rw-r--r--dev-util/chroot-wrapper/chroot-wrapper-0.9.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/chroot-wrapper/chroot-wrapper-0.9.8.ebuild b/dev-util/chroot-wrapper/chroot-wrapper-0.9.8.ebuild
new file mode 100644
index 000000000000..a2ec853be02e
--- /dev/null
+++ b/dev-util/chroot-wrapper/chroot-wrapper-0.9.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Wrapper for chroot to set up some bind mounts, namespaces, and control groups"
+HOMEPAGE="https://github.com/chutz/chroot-wrapper"
+SRC_URI="https://github.com/chutz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ sys-apps/util-linux
+ sys-apps/coreutils
+"
+
+CONFIG_CHECK="
+ ~TMPFS
+ ~IPC_NS
+ ~UTS_NS
+"
+
+src_install() {
+ newsbin src/chroot-wrapper chr
+ insinto /etc/chroot-wrapper
+ doins config.bash
+}