summaryrefslogtreecommitdiff
path: root/dev-util/hfstospell/hfstospell-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hfstospell/hfstospell-0.5.2.ebuild')
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/hfstospell/hfstospell-0.5.2.ebuild b/dev-util/hfstospell/hfstospell-0.5.2.ebuild
new file mode 100644
index 000000000000..f269ab5ace37
--- /dev/null
+++ b/dev-util/hfstospell/hfstospell-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="HFST spell checker library and command line tool"
+HOMEPAGE="https://github.com/hfst/hfst-ospell"
+SRC_URI="https://github.com/hfst/hfst-ospell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/libarchive
+ dev-cpp/libxmlpp:2.6
+ dev-libs/icu:=
+ dev-libs/tinyxml2"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/hfst-ospell-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete -o -name '*.a' -delete || die
+}