summaryrefslogtreecommitdiff
path: root/dev-util/meld/meld-3.22.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/meld/meld-3.22.0-r1.ebuild')
-rw-r--r--dev-util/meld/meld-3.22.0-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-util/meld/meld-3.22.0-r1.ebuild b/dev-util/meld/meld-3.22.0-r1.ebuild
index 8b8cafb1d5ae..6d023ef276db 100644
--- a/dev-util/meld/meld-3.22.0-r1.ebuild
+++ b/dev-util/meld/meld-3.22.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="xml(+)"
-inherit gnome.org meson python-single-r1
+inherit gnome.org meson python-single-r1 xdg
DESCRIPTION="A graphical diff and merge tool"
HOMEPAGE="http://meldmerge.org/"
@@ -62,3 +62,13 @@ src_install() {
python_optimize
python_fix_shebang "${ED}"/usr/bin/meld
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}