summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
index 7196f0b85f19..808cdc0731ae 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -100,7 +100,8 @@ src_compile() {
local conf=(
--build=${CBUILD:-${CHOST}}
--target=${CTARGET}
- --{doc,info,man}dir=/.skip # let individual packages handle docs
+ --{doc,info,man}dir=/.skip # let the real binutils+gcc handle docs
+ MAKEINFO=: #922230
)
# binutils
@@ -239,9 +240,9 @@ src_compile() {
pushd "${build_dir}" >/dev/null || die
edo "${conf[@]}"
- emake V=1
+ emake MAKEINFO=: V=1
# -j1 to match bug #906155, other packages may be fragile too
- emake -j1 V=1 DESTDIR="${MWT_D}" install
+ emake -j1 MAKEINFO=: V=1 DESTDIR="${MWT_D}" install
declare -f mwt-${id} >/dev/null && edo mwt-${id}
declare -f mwt-${id}_${2} >/dev/null && edo mwt-${id}_${2}