summaryrefslogtreecommitdiff
path: root/games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild')
-rw-r--r--games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild47
1 files changed, 24 insertions, 23 deletions
diff --git a/games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild b/games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild
index 53ba592280d8..93180672cd3d 100644
--- a/games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild
+++ b/games-action/armagetronad/armagetronad-0.2.9.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools desktop xdg-utils
+inherit autotools desktop
DESCRIPTION="Fast-paced 3D lightcycle game based on Tron"
HOMEPAGE="http://armagetronad.org/"
@@ -24,9 +24,11 @@ RDEPEND="
virtual/opengl
sound? ( media-libs/sdl-mixer )
)"
-DEPEND=${RDEPEND}
+DEPEND="${RDEPEND}"
-PATCHES=("${FILESDIR}"/${P}-AR.patch)
+PATCHES=(
+ "${FILESDIR}"/${P}-AR.patch
+)
src_prepare() {
default
@@ -35,29 +37,28 @@ src_prepare() {
}
src_configure() {
- # --enable-games just messes up paths
- econf \
- $(use_enable dedicated) \
- $(use_enable sound music) \
- --disable-sysinstall \
- --disable-useradd \
- --disable-uninstall \
+ local econfargs=(
+ $(use_enable dedicated)
+ $(use_enable sound music)
+ # following options only mess with paths and users
--disable-games
+ --disable-sysinstall
+ --disable-uninstall
+ --disable-useradd
+ )
+ econf ${econfargs[@]}
}
src_install() {
- default
-
- # misplaced desktop-file/icons
- rm -r "${ED}"/usr/share/${PN}/desktop || die
- doicon -s 48 desktop/icons/48x48/armagetronad.png
- make_desktop_entry ${PN}
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
+ # long history of being broken without -j1 (bug #330705,698020)
+ # do not remove (again) without a proper fix or extensive tests
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
-pkg_postrm() {
- xdg_icon_cache_update
+ # handle misplaced .desktop / icons
+ if ! use dedicated; then
+ rm -r "${ED}"/usr/share/${PN}/desktop || die
+ doicon desktop/icons/48x48/armagetronad.png
+ make_desktop_entry ${PN}
+ fi
}