summaryrefslogtreecommitdiff
path: root/games-action/shootingstar
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/shootingstar')
-rw-r--r--games-action/shootingstar/Manifest5
-rw-r--r--games-action/shootingstar/files/1.2.0-gcc34.patch23
-rw-r--r--games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch10
-rw-r--r--games-action/shootingstar/metadata.xml8
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0-r1.ebuild53
5 files changed, 99 insertions, 0 deletions
diff --git a/games-action/shootingstar/Manifest b/games-action/shootingstar/Manifest
new file mode 100644
index 000000000000..8cbb6a1b100b
--- /dev/null
+++ b/games-action/shootingstar/Manifest
@@ -0,0 +1,5 @@
+AUX 1.2.0-gcc34.patch 1053 BLAKE2B 7e10e3fa04dcc4431c7991755ede638a59906c2c545d72bff6156825662fc9246e00a4f5dd84e36a6eb8b88c10685ea59938b2aff91bcc20e4f2c341efe46260 SHA512 0941733f645f1fa97dfc860d2f9d33bf6e96a75ada97fd477d60d9aa21a693a067731834df3c31fd2abfde3e7d2a4fe429b8aeeb154100cd730c0713a70cd247
+AUX shootingstar-1.2.0-gcc44.patch 324 BLAKE2B 392579c1792b3863134047f64b0df1d2dfe44ee11eeb640d6b738565ad349cf1df211679121f8e0b0c1ea559fcf0e25a843d4d3dbb675bc5849d2396ea94d893 SHA512 3bda8a966ed6d6536390b228606bc65b4789d8c2adde8e993089b8e63a62bbdceae4d0ec97c3c7f5d87b5b9c3149eb85d4eee64db295b5aa8c67f2f5349b21f1
+DIST shootingstar-1.2.0.tar.gz 7755911 BLAKE2B 22e48044a4a17d7282abd408a6ccc727d60c56da16d170230b287927adb95729a0c6da0b0a9f70ad7d39e647be16dff96cf55aef9e3efbf3396402b4a684527a SHA512 5bc13a444c925ab834482fad7f055ea02eac471f454a3f0ed80e50c3b0956586b7bfa68db82e3034696fa2e8ce5beaf10fc8b8583508e1c29c276469ef7b2b74
+EBUILD shootingstar-1.2.0-r1.ebuild 992 BLAKE2B 366b5cdba862ab7eea6f4bea8e384ac05434c7a1c543f9772e87551655a9751cedceb7e60b229cca2ca61f4a8d4bac23d6dcb99b2db6443f3e6505922d0a4bcc SHA512 cc9efb4a567400d14b86a62081e94f66306322d110c07c3868efdde08b74b8e57101426cdbbe27fcfb05da768e61065529cb4e88e55b40fd4c7a6b57c17041fb
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/shootingstar/files/1.2.0-gcc34.patch b/games-action/shootingstar/files/1.2.0-gcc34.patch
new file mode 100644
index 000000000000..b55997552fc8
--- /dev/null
+++ b/games-action/shootingstar/files/1.2.0-gcc34.patch
@@ -0,0 +1,23 @@
+diff -ur shootingstar-1.2.0/src/engine/cTextureFont.cpp shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp
+--- shootingstar-1.2.0/src/engine/cTextureFont.cpp 2003-07-06 19:31:10.000000000 +0100
++++ shootingstar-1.2.0.loz/src/engine/cTextureFont.cpp 2004-07-26 20:51:16.992768063 +0100
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
++#include <math.h>
+ #include "cTextureManager.hpp"
+ #include "Debug.hpp"
+ //------------------------------------------------------------------------------
+diff -ur shootingstar-1.2.0/src/game/cOptions.cpp shootingstar-1.2.0.loz/src/game/cOptions.cpp
+--- shootingstar-1.2.0/src/game/cOptions.cpp 2003-12-22 05:09:06.000000000 +0000
++++ shootingstar-1.2.0.loz/src/game/cOptions.cpp 2004-07-26 21:00:25.265284270 +0100
+@@ -201,7 +201,7 @@
+ dbgError () << "Unable to read from options file\n";
+ throw runtime_error ("Unable to load options");
+ }
+- int (keys.keys[i]) = key; // IS THIS SAFE?
++ keys.keys[i] = (SDLKey)key; // IS THIS SAFE?
+
+ fin >> key;
+ keys.buttons[i] = key;
diff --git a/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
new file mode 100644
index 000000000000..dfc1a8d8e77e
--- /dev/null
+++ b/games-action/shootingstar/files/shootingstar-1.2.0-gcc44.patch
@@ -0,0 +1,10 @@
+--- a/src/engine/dbg.cpp 2009-06-03 15:15:46.000000000 +0200
++++ b/src/engine/dbg.cpp 2009-06-03 16:09:19.000000000 +0200
+@@ -28,6 +28,7 @@
+ #include <vector>
+ #include <map>
+ #include <algorithm>
++#include <cstdio>
+
+ /**********************************************************************
+ * Implementation notes
diff --git a/games-action/shootingstar/metadata.xml b/games-action/shootingstar/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/shootingstar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..11411f402d59
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+# Note: currently segfaults on startup, but that's also in the previous ebuild
+# See https://bugs.gentoo.org/607428
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gcc34.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install () {
+ default
+ newicon -s 128 data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}