summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/Manifest8
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild69
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629.ebuild51
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild74
-rw-r--r--games-emulation/dosbox/files/dosbox-0.74-gcc46.patch10
-rw-r--r--games-emulation/dosbox/metadata.xml19
6 files changed, 231 insertions, 0 deletions
diff --git a/games-emulation/dosbox/Manifest b/games-emulation/dosbox/Manifest
new file mode 100644
index 000000000000..872b32c2d143
--- /dev/null
+++ b/games-emulation/dosbox/Manifest
@@ -0,0 +1,8 @@
+AUX dosbox-0.74-gcc46.patch 274 BLAKE2B 6375a8c0752eed6481cfc987ac3b7c7f699d745498e619862223dcbf660eef21f7619ef5b8e2034d20ad09716714988875e30d1959fe29393fd96559a2d710df SHA512 3175ba75be568d24286501844073bebbd2ae2e770ca6bdd9d409b290ca7b9f98a8406b5b92b89a9965eeda8045f2ac9634aacf8eb01917cbf02087996de53177
+DIST dosbox-code-0-3989-dosbox-trunk.zip 1327592 BLAKE2B 7a9eccd381c1ce7a08d6e650d94de9e82aa5fb1b63abd23b0f42d10d95df4ca2ba4b2c319f3375e030c1578f032ee7bde528f9c4bbc27b665733f7d035865376 SHA512 625eacc1a1190d87d56713f7af54e6a7886e7666ba9f7f0b1d553c96a2eb02ec7810ac2da73d014d5ea3b69f2a7658bdd445532abe030e7f6ef85a3c20bdd3c7
+DIST dosbox_glide-3722fc563b737d2d7933df6a771651c2154e6f7b.diff 96346 BLAKE2B c22d8897b3767b3351aec4d7bd64d201c32e2191c0520478f33973b0b36652e9770f571ea32fee6d30a4de35cae1c4d223d56af070b3f3916f6827ab47ec0585 SHA512 d2be6ee8bd1f13058c76ccae595b67f15ab87e0e36dab0d938ebbd7fc5d379f6f054d30c32ef4723b9fcdbbcea7bf0e1aa2c8b1aab1737f1d0e4d2a2df0f7714
+DIST dosbox_glide-841e1071597b64ead14dd08c25a03206b2d1d1b6.diff 96801 BLAKE2B d24d1f4262129899d807c275b1ae2d6c09056a126441665f37359302428f30576f399c4778b55f4eaec674e714d85243f576bfa3064887c5801daddc9e507aad SHA512 4cbe0ede9c4242aa346ca6c609b7a4d8e4e1d204d79d93ff741d58d3ca14e43a2e49cd696bd4bd54c13e62d1080320ee233963bac26f25bb0b4fada86e813ca2
+EBUILD dosbox-0.74_p20160629-r1.ebuild 1787 BLAKE2B 7a7c60b909d4a4b4e424d5baa03b5ca7247697c6d993f5aed8690d9eb35b708e62626febc56b94dbd7ca70ecbfd3b93ce4327128e2272a97f5ff1ddd26307a03 SHA512 f4e67047d01f2ca91fa446136ec2829c589c37f2cca664e1ff1292a5ec78fa8a44f78defcdfd23e556ffa2a2d3b2f9a403e4178f3dca36b5ea58307ca1c52889
+EBUILD dosbox-0.74_p20160629.ebuild 1074 BLAKE2B 1d8f874307886cd84f6573784e4d1af6117841c49242352a57109b82879a58ae12a8a512f40eb65fc64b3e294455d278671f3ee7dd46497569954219c566a8a6 SHA512 00edfb8cf1fa3b1f7bee6ef96b5dee033cf1ca48737e9f00a4ddbe09b29c717cf2ae1f10577ca29fa4b886ec7a28f2131e1e12dc41fed5a4c5831b0194ce58b8
+EBUILD dosbox-9999.ebuild 1884 BLAKE2B d5fb6c6b1f123e83d960dd3ff7323845e9ab2673aa889c08d4dc660e18617503b56dfd765f405cb03d3509e88e1cb78242c96b37161a263b966c7fc54eec25a3 SHA512 9ae090a3377bc63b13cb6b6325ffdc36e1cd3a1df512f5c50d1334005a41893dbb6459e008594fe8550fb31948b1f149913bd641fc281fdffea2a7b7e5cfb970
+MISC metadata.xml 623 BLAKE2B 2ff1106b2288c775d3bcff26145af604b63edd350f28ff3fd9c8407a738910d080425fa635b6b03436b0b8c24dde9c7dbd342df1f1bacdfacc391246db565ac0 SHA512 a7aff1ef1c4c2c97e8287b3aec84c1c270b8d052e12d4719704a6732575f1f62e4f9024af3d4e1f234e18c3d47aec863bdf6e6472e03cabd24124e7473c28e87
diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
new file mode 100644
index 000000000000..f622d980d347
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+PATCH=3989
+GLIDE_PATCH=3722fc563b737d2d7933df6a771651c2154e6f7b
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://gentoo/dosbox-code-0-${PATCH}-dosbox-trunk.zip
+ glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="alsa debug glide hardened opengl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ glide? ( media-libs/openglide )
+ opengl? ( virtual/glu virtual/opengl )
+ debug? ( sys-libs/ncurses:0 )
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,video,X]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
+
+PATCHES=(
+"${FILESDIR}"/dosbox-0.74-gcc46.patch
+)
+
+src_prepare() {
+ use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use glide && append-cppflags -I"${EPREFIX}"/usr/include/openglide
+
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-core) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ default
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+}
+
+pkg_postinst() {
+ if use glide; then
+ elog "You have enabled unofficial Glide emulation. To use this, symlink"
+ elog "or copy ${EPREFIX}/usr/share/openglide/glide2x-dosbox.ovl to your game's"
+ elog "directory and add the following to your DOSBox configuration."
+ elog ""
+ elog "[glide]"
+ elog "glide=true"
+ fi
+}
diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
new file mode 100644
index 000000000000..45b0b0fdb711
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+PATCH=3989
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://gentoo/dosbox-code-0-${PATCH}-dosbox-trunk.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc64 x86"
+IUSE="alsa debug hardened opengl"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/glu virtual/opengl )
+ debug? ( sys-libs/ncurses:0 )
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,video,X]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
+
+PATCHES=(
+"${FILESDIR}"/dosbox-0.74-gcc46.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-core) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ default
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+}
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
new file mode 100644
index 000000000000..bceaab9e8150
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GLIDE_PATCH=841e1071597b64ead14dd08c25a03206b2d1d1b6
+SRC_URI="glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
+
+if [[ ${PV} = 9999 ]]; then
+ ESVN_REPO_URI="https://svn.code.sf.net/p/dosbox/code-0/dosbox/trunk"
+ inherit subversion
+else
+ SRC_URI+=" mirror://sourceforge/dosbox/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="alsa debug glide hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ glide? ( media-libs/openglide )
+ opengl? ( virtual/glu virtual/opengl )
+ debug? ( sys-libs/ncurses:0 )
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,video,X]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+RDEPEND=${DEPEND}
+
+if [[ ${PV} = 9999 ]]; then
+ S=${WORKDIR}/${PN}
+fi
+
+PATCHES=( "${FILESDIR}/${PN}-0.74-gcc46.patch" )
+
+src_prepare() {
+ use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use glide && append-cppflags -I"${EPREFIX}"/usr/include/openglide
+
+ econf \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-core) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ default
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+}
+
+pkg_postinst() {
+ if use glide; then
+ elog "You have enabled unofficial Glide emulation. To use this, symlink"
+ elog "or copy ${EPREFIX}/usr/share/openglide/glide2x-dosbox.ovl to your game's"
+ elog "directory and add the following to your DOSBox configuration."
+ elog ""
+ elog "[glide]"
+ elog "glide=true"
+ fi
+}
diff --git a/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
new file mode 100644
index 000000000000..98b4508f519f
--- /dev/null
+++ b/games-emulation/dosbox/files/dosbox-0.74-gcc46.patch
@@ -0,0 +1,10 @@
+--- a/include/dos_inc.h 2011-04-28 08:46:04.505011354 +0200
++++ b/include/dos_inc.h 2011-04-28 08:46:27.104408178 +0200
+@@ -21,6 +21,7 @@
+ #ifndef DOSBOX_DOS_INC_H
+ #define DOSBOX_DOS_INC_H
+
++#include <cstddef>
+ #ifndef DOSBOX_DOS_SYSTEM_H
+ #include "dos_system.h"
+ #endif
diff --git a/games-emulation/dosbox/metadata.xml b/games-emulation/dosbox/metadata.xml
new file mode 100644
index 000000000000..4c30301896f0
--- /dev/null
+++ b/games-emulation/dosbox/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Gentoo Wine Project</name>
+ <description>Should be cc'ed for issues with dosbox-0.74-_p* snapshot versions</description>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">dosbox</remote-id>
+</upstream>
+<use>
+ <flag name="glide">Enable unofficial Glide emulation via media-libs/openglide</flag>
+</use>
+</pkgmetadata>