summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-rsp-hle
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-rsp-hle')
-rw-r--r--games-emulation/mupen64plus-rsp-hle/Manifest2
-rw-r--r--games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0-r1.ebuild68
2 files changed, 0 insertions, 70 deletions
diff --git a/games-emulation/mupen64plus-rsp-hle/Manifest b/games-emulation/mupen64plus-rsp-hle/Manifest
index 0db048f50353..e5c156f654bb 100644
--- a/games-emulation/mupen64plus-rsp-hle/Manifest
+++ b/games-emulation/mupen64plus-rsp-hle/Manifest
@@ -1,5 +1,3 @@
-DIST mupen64plus-rsp-hle-src-2.0.tar.gz 46291 BLAKE2B a150bb8da00be27fedb0141eb39cccc895668bafc8553aa65f37a6b3abd2988b72bae8cbdfe64c0a997a558a472d3bedaee0a81e8733e73a7efe687268bd6321 SHA512 e1caa121d377be0856708fa5c13c234abc0bbb2cab90f40963983baf6230a1d4a4b7da9af0fa2ed6737538265b6392d8a43e9e537ccbd63bbb6ee44da8b29fdf
DIST mupen64plus-rsp-hle-src-2.5.tar.gz 46998 BLAKE2B 3bb5ee627fa4c367e7dd1ef0ac0a1eae1267cf82ac66a35f4dcd972703b9cba832224cab1be20c75e9f61af2afae0c8eb7dd6ba806a47c57eef6e6c5da9e8a5a SHA512 564d96050890cc61df05163f99a0be8198e870f0d4071e87828bf58b283b2be8ca7de20ed03482ea8c45725bdd6f6baea618c068cced407892cf2add6ef373c6
-EBUILD mupen64plus-rsp-hle-2.0-r1.ebuild 1435 BLAKE2B 5568b185559e3c6a5785f696fe81c612df394fef03322a365aca1d0f8d566ba8192d84fd7884cf423fefc66d45a026ead20ef834e6bff730f339e7f033c9672e SHA512 27e3c65ff9d57bf70dc9894f3e90962971d069aecc06f7c9db2dadae82af36f1fb0d2bbe10c70a8f8ce01378382ca8216ca05c7d9aab4ec9ded7ce919021eaba
EBUILD mupen64plus-rsp-hle-2.5.ebuild 1435 BLAKE2B 5568b185559e3c6a5785f696fe81c612df394fef03322a365aca1d0f8d566ba8192d84fd7884cf423fefc66d45a026ead20ef834e6bff730f339e7f033c9672e SHA512 27e3c65ff9d57bf70dc9894f3e90962971d069aecc06f7c9db2dadae82af36f1fb0d2bbe10c70a8f8ce01378382ca8216ca05c7d9aab4ec9ded7ce919021eaba
MISC metadata.xml 343 BLAKE2B 997f47a4d8c1fccab5b16dd49ab4e791ec1ae114b820ad75839f981e9a72f409951a22abfbb68788ade5dcb1be2dd91aba4fc9771c00519307ee28455ab7aa9d SHA512 7ffba7fdacc44215dba6cf994646ea38ebf94870accc3d6150ca609fcf5dc7b343a52fe6fc0511e5741f24afc20b11c2e1104d39215f7cffdeaf1098efaf709e
diff --git a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0-r1.ebuild b/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0-r1.ebuild
deleted file mode 100644
index b326e6251588..000000000000
--- a/games-emulation/mupen64plus-rsp-hle/mupen64plus-rsp-hle-2.0-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_P=${PN}-src-${PV}
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, HLE RSP plugin"
-HOMEPAGE="http://www.mupen64plus.org/"
-SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=games-emulation/mupen64plus-core-2.0-r1:0="
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch_user
-
- # avoid implicitly appending CPU flags
- sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
-}
-
-src_compile() {
- MAKEARGS=(
- # Note: please keep this in sync in all of mupen64plus-* packages
-
- -C projects/unix
-
- # this basically means: GNU userspace
- UNAME=Linux
-
- # verbose output
- V=1
-
- CROSS_COMPILE="${CHOST}-"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
- # so we can leave OPTFLAGS empty
- OPTFLAGS=
-
- # paths, some of them are used at compile time
- PREFIX=/usr
- LIBDIR=/usr/$(get_libdir)
-
- # disable unwanted magic
- LDCONFIG=:
- INSTALL_STRIP_FLAG=
- )
-
- use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
- use x86 && MAKEARGS+=( HOST_CPU=i386 )
-
- emake "${MAKEARGS[@]}" all
-}
-
-src_install() {
- emake "${MAKEARGS[@]}" DESTDIR="${D}" install
- einstalldocs
-}