summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2/files/pcsx2-1.7.5855-no-libbacktrace.patch
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/pcsx2/files/pcsx2-1.7.5855-no-libbacktrace.patch')
-rw-r--r--games-emulation/pcsx2/files/pcsx2-1.7.5855-no-libbacktrace.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/files/pcsx2-1.7.5855-no-libbacktrace.patch b/games-emulation/pcsx2/files/pcsx2-1.7.5855-no-libbacktrace.patch
new file mode 100644
index 000000000000..548f90e8ec1f
--- /dev/null
+++ b/games-emulation/pcsx2/files/pcsx2-1.7.5855-no-libbacktrace.patch
@@ -0,0 +1,30 @@
+libbacktrace used to be packaged in Gentoo but was last-rited due
+to [1], and as of [2] pcsx2 no longer let it be optional albeit the
+code to allow this still exists behind __APPLE__ which lacks it.
+
+May be revisited to see if re-packaging may be sane (not looked
+into the issue much, could potentially mask libbacktrace and pcsx2
+on musl, or even bundle libbacktrace), but for now drop the
+dependency again as it is fairly trivial.
+
+[1] https://bugs.gentoo.org/885471
+[2] https://github.com/PCSX2/pcsx2/commit/d48f527d6d88dfbf87
+--- a/cmake/SearchForStuff.cmake
++++ b/cmake/SearchForStuff.cmake
+@@ -71,3 +71,2 @@
+
+- find_package(Libbacktrace REQUIRED)
+ find_package(PkgConfig REQUIRED)
+--- a/common/CMakeLists.txt
++++ b/common/CMakeLists.txt
+@@ -161,3 +161,2 @@
+ ${DBUS_LINK_LIBRARIES}
+- libbacktrace::libbacktrace
+ X11::X11
+--- a/common/CrashHandler.cpp
++++ b/common/CrashHandler.cpp
+@@ -178,3 +178,3 @@
+
+-#elif !defined(__APPLE__)
++#elif 0
+