summaryrefslogtreecommitdiff
path: root/games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild')
-rw-r--r--games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild b/games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild
index b174a76f1f3c..39c109b7be99 100644
--- a/games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild
+++ b/games-puzzle/angrydd/angrydd-1.0.1_p13-r2.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit desktop python-single-r1
DESCRIPTION="Angry, Drunken Dwarves, a falling blocks game similar to Puzzle Fighter"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="
mirror://gentoo/${P/_p*}.tar.gz
- mirror://debian/pool/main/${P::1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz"
-S="${WORKDIR}/${P/_p*}"
+ mirror://debian/pool/main/${P::1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+"
+S=${WORKDIR}/${P/_p*}
LICENSE="GPL-2"
SLOT="0"
@@ -22,7 +23,8 @@ RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-python/pygame[${PYTHON_USEDEP}]')
media-libs/sdl2-image[png]
- media-libs/sdl2-mixer[vorbis]"
+ media-libs/sdl2-mixer[vorbis]
+"
BDEPEND="${PYTHON_DEPS}"
PATCHES=(
@@ -42,5 +44,5 @@ src_install() {
doicon ${PN}.png
make_desktop_entry ${PN} "Angry, Drunken Dwarves"
- rm -r "${ED}"/usr/share/{games,share} || die
+ rm -r -- "${ED}"/usr/share/{games,share} || die
}