summaryrefslogtreecommitdiff
path: root/media-libs/libnsgif/libnsgif-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libnsgif/libnsgif-9999.ebuild')
-rw-r--r--media-libs/libnsgif/libnsgif-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libnsgif/libnsgif-9999.ebuild b/media-libs/libnsgif/libnsgif-9999.ebuild
new file mode 100644
index 000000000000..53cb45fba3c3
--- /dev/null
+++ b/media-libs/libnsgif/libnsgif-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 netsurf
+
+DESCRIPTION="decoding library for the GIF image file format, written in C"
+HOMEPAGE="https://www.netsurf-browser.org/projects/libnsgif/"
+
+EGIT_REPO_URI="https://git.netsurf-browser.org/${PN}.git"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+BDEPEND="
+ dev-util/netsurf-buildsystem
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+}
+
+_emake() {
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}