summaryrefslogtreecommitdiff
path: root/media-libs/simage/files/simage-1.7.1-disable-examples.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/simage/files/simage-1.7.1-disable-examples.patch')
-rw-r--r--media-libs/simage/files/simage-1.7.1-disable-examples.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/simage/files/simage-1.7.1-disable-examples.patch b/media-libs/simage/files/simage-1.7.1-disable-examples.patch
new file mode 100644
index 000000000000..9e43e073ccd1
--- /dev/null
+++ b/media-libs/simage/files/simage-1.7.1-disable-examples.patch
@@ -0,0 +1,44 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5536922..07df95a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -482,23 +482,23 @@ endif()
+ # Build examples
+ # ############################################################################
+
+-set(SIMAGE_EXAMPLE_SOURCE
+- ${CMAKE_CURRENT_SOURCE_DIR}/examples/audio2raw.c
+- ${CMAKE_CURRENT_SOURCE_DIR}/examples/img2avi.c
++#set(SIMAGE_EXAMPLE_SOURCE
++# ${CMAKE_CURRENT_SOURCE_DIR}/examples/audio2raw.c
++# ${CMAKE_CURRENT_SOURCE_DIR}/examples/img2avi.c
+ # ${CMAKE_CURRENT_SOURCE_DIR}/examples/mpeg2enc.cpp # requires Coin to build
+- ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-convert.c
+- ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-read-line-test.c
+-)
+-
+-foreach(_source ${SIMAGE_EXAMPLE_SOURCE})
+- get_filename_component(_example ${_source} NAME_WE)
+- add_executable(${_example} ${_source})
+- target_compile_definitions(${_example} PRIVATE _CRT_NONSTDC_NO_DEPRECATE _CRT_SECURE_NO_DEPRECATE _CRT_SECURE_NO_WARNINGS _USE_MATH_DEFINES)
+- target_link_libraries(${_example} simage)
+- if(UNIX)
+- target_link_libraries(${_example} m)
+- endif()
+-endforeach()
++# ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-convert.c
++# ${CMAKE_CURRENT_SOURCE_DIR}/examples/simage-read-line-test.c
++#)
++
++#foreach(_source ${SIMAGE_EXAMPLE_SOURCE})
++# get_filename_component(_example ${_source} NAME_WE)
++# add_executable(${_example} ${_source})
++# target_compile_definitions(${_example} PRIVATE _CRT_NONSTDC_NO_DEPRECATE _CRT_SECURE_NO_DEPRECATE _CRT_SECURE_NO_WARNINGS _USE_MATH_DEFINES)
++# target_link_libraries(${_example} simage)
++# if(UNIX)
++# target_link_libraries(${_example} m)
++# endif()
++#endforeach()
+
+ # ############################################################################
+ # Build tests