summaryrefslogtreecommitdiff
path: root/media-radio/xdx/xdx-2.91.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/xdx/xdx-2.91.ebuild')
-rw-r--r--media-radio/xdx/xdx-2.91.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-radio/xdx/xdx-2.91.ebuild b/media-radio/xdx/xdx-2.91.ebuild
new file mode 100644
index 000000000000..1ded92afeb98
--- /dev/null
+++ b/media-radio/xdx/xdx-2.91.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="a GTK+ TCP/IP DX-cluster and ON4KST chat client"
+HOMEPAGE="https://sourceforge.net/projects/xdxclusterclient"
+SRC_URI="mirror://sourceforge/xdxclusterclient/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:3
+ dev-libs/glib
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "To use the rig control feature, install media-libs/hamlib"
+ elog "and enable hamlib in the Preferences dialog. (no need for recompile)"
+}