summaryrefslogtreecommitdiff
path: root/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch')
-rw-r--r--media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch b/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch
new file mode 100644
index 000000000000..e4b3bf0304c9
--- /dev/null
+++ b/media-sound/tomahawk/files/tomahawk-qtkeychain-cmake.patch
@@ -0,0 +1,28 @@
+From 00f602e10203b76fc28b4615868c567e6bd4ced4 Mon Sep 17 00:00:00 2001
+From: Dominik Schmidt <dev@dominik-schmidt.de>
+Date: Tue, 8 Aug 2017 14:34:49 +0200
+Subject: [PATCH] Fix #619: Correctly detect qt5keychain
+
+---
+ CMakeLists.txt | 8 ++------
+ 1 file changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ad5d918ecf..7004e1b700 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -376,12 +376,8 @@ macro_optional_find_package(LibLastFm 1.0.0)
+ macro_log_feature(LIBLASTFM_FOUND "liblastfm" "Qt library for the Last.fm webservices" "https://github.com/lastfm/liblastfm" TRUE "" "liblastfm is needed for scrobbling tracks to Last.fm and fetching cover artwork")
+
+ if( NOT APPLE )
+-if( TOMAHAWK_QT5 )
+- macro_optional_find_package(Qt5Keychain 0.1.0)
+-else()
+- macro_optional_find_package(QtKeychain 0.1.0)
+-endif()
+-macro_log_feature(QTKEYCHAIN_FOUND "QtKeychain" "Provides support for secure credentials storage" "https://github.com/frankosterfeld/qtkeychain" TRUE "" "")
++macro_optional_find_package(Qt5Keychain 0.1.0)
++macro_log_feature(Qt5Keychain_FOUND "QtKeychain" "Provides support for secure credentials storage" "https://github.com/frankosterfeld/qtkeychain" TRUE "" "")
+ endif()
+
+ if( UNIX AND NOT APPLE )