summaryrefslogtreecommitdiff
path: root/net-analyzer/net-snmp/net-snmp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/net-snmp/net-snmp-9999.ebuild')
-rw-r--r--net-analyzer/net-snmp/net-snmp-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-9999.ebuild b/net-analyzer/net-snmp/net-snmp-9999.ebuild
index 8d46910e24ac..c7a25ac6302a 100644
--- a/net-analyzer/net-snmp/net-snmp-9999.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-9999.ebuild
@@ -30,7 +30,7 @@ LICENSE="HPND BSD GPL-2"
SLOT="0/40"
IUSE="
X bzip2 doc elf kmem ipv6 lm-sensors mfd-rewrites minimal mysql
- netlink pcap pci perl python rpm selinux smux ssl tcpd ucd-compat zlib
+ netlink pcap pci pcre perl python rpm selinux smux ssl tcpd ucd-compat valgrind zlib
"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
@@ -47,6 +47,7 @@ COMMON_DEPEND="
netlink? ( dev-libs/libnl:3 )
pcap? ( net-libs/libpcap )
pci? ( sys-apps/pciutils )
+ pcre? ( dev-libs/libpcre )
perl? ( dev-lang/perl:= )
python? (
$(python_gen_cond_dep '
@@ -65,7 +66,10 @@ COMMON_DEPEND="
zlib? ( >=sys-libs/zlib-1.1.4 )
"
BDEPEND="doc? ( app-doc/doxygen )"
-DEPEND="${COMMON_DEPEND}"
+DEPEND="
+ ${COMMON_DEPEND}
+ valgrind? ( dev-util/valgrind )
+"
RDEPEND="
${COMMON_DEPEND}
perl? (
@@ -129,6 +133,8 @@ src_configure() {
# Assume /etc/mtab is not present with a recent baselayout/openrc (bug #565136)
use kernel_linux && export ac_cv_ETC_MNTTAB=/etc/mtab
+ export ac_cv_header_valgrind_{valgrind,memcheck}_h=$(usex valgrind)
+
econf \
$(use_enable !ssl internal-md5) \
$(use_enable ipv6) \
@@ -142,6 +148,7 @@ src_configure() {
$(use_with netlink nl) \
$(use_with pcap) \
$(use_with pci) \
+ $(use_with pcre) \
$(use_with perl perl-modules INSTALLDIRS=vendor) \
$(use_with python python-modules) \
$(use_with rpm) \