summaryrefslogtreecommitdiff
path: root/net-analyzer/tcping/tcping-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcping/tcping-2.1.0.ebuild')
-rw-r--r--net-analyzer/tcping/tcping-2.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/tcping/tcping-2.1.0.ebuild b/net-analyzer/tcping/tcping-2.1.0.ebuild
new file mode 100644
index 000000000000..b7f426393c4b
--- /dev/null
+++ b/net-analyzer/tcping/tcping-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Check if a desired port is reachable via TCP"
+HOMEPAGE="https://github.com/mkirchner/tcping"
+SRC_URI="https://github.com/mkirchner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}