summaryrefslogtreecommitdiff
path: root/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r1.ebuild')
-rw-r--r--net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r1.ebuild b/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r1.ebuild
new file mode 100644
index 000000000000..501856d25c2c
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="RTSP conntrack module for Netfilter"
+HOMEPAGE="http://mike.it-loops.com/rtsp"
+SRC_URI="https://github.com/maru-sama/rtsp-linux/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/rtsp-linux-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CONFIG_CHECK="NF_CONNTRACK"
+
+src_compile() {
+ local modlist=(
+ nf_conntrack_rtsp=net/netfilter:::all
+ nf_nat_rtsp=net/ipv4/netfilter:::all
+ )
+ local modargs=( KERNELDIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}