summaryrefslogtreecommitdiff
path: root/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libyahoo2/libyahoo2-1.0.1.ebuild')
-rw-r--r--net-libs/libyahoo2/libyahoo2-1.0.1.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
index 66739a597faf..0cd41ed48213 100644
--- a/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
+++ b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="interface to the new Yahoo! Messenger protocol"
HOMEPAGE="http://libyahoo2.sourceforge.net/"
@@ -11,40 +11,33 @@ SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="libressl ssl static-libs"
+IUSE="static-libs ssl"
RDEPEND="dev-libs/glib:2
- ssl? (
- libressl? ( dev-libs/libressl:0= )
- !libressl? ( dev-libs/openssl:0= )
- )
-"
+ ssl? ( dev-libs/openssl )"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${FILESDIR}/${P}-asneeded.patch"
-)
-
src_prepare() {
- default
+ epatch "${FILESDIR}"/${P}-asneeded.patch
sed -i -e 's:-ansi -pedantic::' configure.ac || die #240912
eautoreconf
}
src_configure() {
econf \
+ --disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_enable ssl sample-client)
}
src_install() {
- default
+ emake DESTDIR="${D}" install || die
if use ssl; then
- dobin src/.libs/{autoresponder,yahoo}
+ dobin src/.libs/{autoresponder,yahoo} || die
fi
- dodoc doc/*.txt
+ dodoc AUTHORS ChangeLog doc/*.txt NEWS README TODO
- find "${D}" -name '*.la' -delete || die "Pruning failed"
+ find "${D}" -name '*.la' -exec rm -f '{}' +
}