summaryrefslogtreecommitdiff
path: root/net-libs/libzapojit/libzapojit-0.0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libzapojit/libzapojit-0.0.3-r1.ebuild')
-rw-r--r--net-libs/libzapojit/libzapojit-0.0.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libzapojit/libzapojit-0.0.3-r1.ebuild b/net-libs/libzapojit/libzapojit-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..fba7e8314bc6
--- /dev/null
+++ b/net-libs/libzapojit/libzapojit-0.0.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="GLib/GObject wrapper for the SkyDrive and Hotmail REST APIs"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libzapojit"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/libsoup-2.38:2.4
+ dev-libs/json-glib
+ net-libs/rest
+ net-libs/gnome-online-accounts
+
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common:3
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+}