summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-16.20.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-16.20.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-16.20.0.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/net-libs/nodejs/nodejs-16.20.0.ebuild b/net-libs/nodejs/nodejs-16.20.0.ebuild
index b5937a82e94c..674133fd6675 100644
--- a/net-libs/nodejs/nodejs-16.20.0.ebuild
+++ b/net-libs/nodejs/nodejs-16.20.0.ebuild
@@ -20,7 +20,7 @@ if [[ ${PV} == *9999 ]]; then
else
SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
SLOT="0/$(ver_cut 1)"
- KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
+ KEYWORDS="amd64 arm arm64 ppc64 ~riscv ~x86 ~amd64-linux ~x64-macos"
S="${WORKDIR}/node-v${PV}"
fi
@@ -93,13 +93,6 @@ src_prepare() {
# We need to disable mprotect on two files when it builds Bug 694100.
use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-16.4.2-paxmarking.patch )
- # All this test does is check if the npm CLI produces warnings of any sort,
- # failing if it does. Overkill, much? Especially given one possible warning
- # is that there is a newer version of npm available upstream (yes, it does
- # use the network if available), thus making it a real possibility for this
- # test to begin failing one day even though it was fine before.
- rm -f test/parallel/test-release-npm.js
-
default
}
@@ -222,11 +215,16 @@ src_install() {
}
src_test() {
- if has usersandbox ${FEATURES}; then
- rm -f "${S}"/test/parallel/test-fs-mkdir.js
- ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
- "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
- fi
+ local drop_tests=(
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-utimes-y2K38.js
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-error.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ rm "${drop_tests[@]}" || die "disabling tests failed"
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die