summaryrefslogtreecommitdiff
path: root/net-misc/openvswitch
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/Manifest2
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.9.ebuild173
2 files changed, 175 insertions, 0 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index fdf2da39aeef..201668cbe277 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -10,6 +10,8 @@ AUX ovsdb-server_conf2 580 BLAKE2B dfd1ece1fe4799439c097cf87175b6d6b331fce4a920c
AUX xcp-interface-reconfigure-2.3.2.patch 920 BLAKE2B a0cf230e9793484309ec38a6faf7ba386ae4e1ba7b8c77e3a3f0cbdef63d128dd765362e4ab8077da04a60444718283cc68d0a402ed12fa168c2ca983c1064a6 SHA512 7f2dd6fbd3f734abe2cf8e23a0aa49d81a8acb26ac5c28004a95ec0fe4630f7792aabdaeb8825a62ff96fcf1c3a871eea10b11c6b92ddf7965aa1f73150f7ec7
DIST openvswitch-2.17.6.tar.gz 8092331 BLAKE2B 0564a332e8c876552a9a3a068f4e54d3f5d56428e277e32f188aba9626035818c900be45171964ddcb782166a5e5b3b8f3a2fb80d5ed9723b94c9e1ed7410544 SHA512 ff9d19a9101c9a18117a859150d391eecbd6a331e35da3f20a62acaac1febbfbad716874734f9bd0d304d635212884f9f617b944e79bb7e554ddd9e5c53645c8
DIST openvswitch-2.17.8.tar.gz 8097747 BLAKE2B d37ae60481255476d41aa94086f6a597107b23176f7ff47eeff9d85a5904da3685886663451317e0b9e512fb049b4024e291f320752aa90fe798ff08f49772c5 SHA512 c94685b67f9f25c81a590696d36c431fadf09c2504b06565011c2945ef242c5039508b312992597822f8ee274ce615ca58bc6bb2aa0a9cf1346bc2dcada70fa1
+DIST openvswitch-2.17.9.tar.gz 8136490 BLAKE2B cdb5ec81fb9ac04786fc1230d60c6c9bbf7ec2929cf5ab40bb1e0e7442480383d0ad8f24f14df4901cab8f39a6532445cf1810c9b9e3a779d7d15bfe35101a37 SHA512 b91212f9c10a208bca9d15cd5a219ae24b7e9bf8b5c8fdebc21cd9fa8229bc655f9f3591d79dd30c1a8212daed15d5a26bf9532b3496e3660bc8b62012f45636
EBUILD openvswitch-2.17.6.ebuild 5256 BLAKE2B 60504d26e5f14d6fbc986d901cd7843f94daf39185c59b92c027a5f7372fb0a8fc3479dc4662b6f01871b899d0968032b42905e88534307d33099ac2fd0d1c15 SHA512 8443172dade0e5a0f2bd0ec6af8e69269fde4473255477108c16db1540443664644ac456d3bf271002f5b4f20d169f837f7cf6858a8214f652f7e04e2efaa539
EBUILD openvswitch-2.17.8.ebuild 5268 BLAKE2B 5f42a771aeae71d10e5af453f86e44c3b33511614b438cac6a7ede9c71bfffb41d305828a23170a6efc51a0efdb6bf713ad99689b3e9dc152211de734afeb36a SHA512 025747ed646b6e9ba61f9da57208a118a0b00ac73aa8d9f2013683cf5d34170a7187ef6fbd60938588bc464059d59d305837634a4afad4e454437f2012842c4d
+EBUILD openvswitch-2.17.9.ebuild 5218 BLAKE2B d6a214a90b3937dd6a057c73926abfeafab4fc774589c95cd804fc8db19c9ebb1c8dc2c167765ad51ce5a0bde80ac81c5d6f2b4e8924f9518f8633c585914d9f SHA512 25eefed91c56016814af5f325fd837bbcac94a8c64b9aae84b24a504b36df276ccc5d809d07e63b59ace8a4ceb1c2c7998d56bc0e8e7e0ac8b2651d631f7dd2c
MISC metadata.xml 539 BLAKE2B c6a7e8b9ffb18bd32be27bb2ba301b4b8872a0c17eec6b110f89562d261614ca9bc1a5d89350ac05b6dc26d7536fd7aa1920326c7f55a0ecb4693bfc99986810 SHA512 d731202dfe79480263006596d7da8349a6831e05d75d5ebc9cce28818d02d5a52e81b350f5afb06279e91e5dc700763fb2975b28aad15bc3a0ea72b6264eba71
diff --git a/net-misc/openvswitch/openvswitch-2.17.9.ebuild b/net-misc/openvswitch/openvswitch-2.17.9.ebuild
new file mode 100644
index 000000000000..5443b1d05e16
--- /dev/null
+++ b/net-misc/openvswitch/openvswitch-2.17.9.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MODULES_OPTIONAL_USE="modules"
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit autotools linux-mod-r1 python-single-r1 systemd tmpfiles
+
+DESCRIPTION="Production quality, multilayer virtual switch"
+HOMEPAGE="https://www.openvswitch.org"
+SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+IUSE="debug modules monitor +ssl unwind valgrind"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Check python/ovs/version.py in tarball for dev-python/ovs dep
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ ~dev-python/ovs-2.17.1_p1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ ')
+ debug? ( dev-lang/perl )
+ unwind? ( sys-libs/libunwind:= )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}
+ sys-apps/util-linux[caps]
+ valgrind? ( dev-debug/valgrind )"
+BDEPEND="virtual/pkgconfig
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')"
+
+PATCHES=(
+ "${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
+)
+
+CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
+MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ if use modules ; then
+ CONFIG_CHECK+=" ~!OPENVSWITCH"
+ kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
+ kernel_is le 5 8 999 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
+ linux-mod-r1_pkg_setup
+ else
+ CONFIG_CHECK+=" ~OPENVSWITCH"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Never build kernelmodules, doing this manually
+ sed -i \
+ -e '/^SUBDIRS/d' \
+ datapath/Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ set_arch_to_kernel
+ python_setup
+
+ # monitor is statically enabled for bug #596206
+ # use monitor || export ovs_cv_python="no"
+ # pyside is staticly disabled
+ export ovs_cv_pyuic4="no"
+
+ # flake8 is primarily a style guide tool, running it as part of the tests
+ # in Gentoo does not make much sense, only breaks them: bug #607280
+ export ovs_cv_flake8="no"
+
+ # Only adds a diagram to the man page, just skip it as we don't
+ # want to add a BDEPEND on graphviz right now. bug #856286
+ export ovs_cv_dot="no"
+
+ export ac_cv_header_valgrind_valgrind_h=$(usex valgrind)
+
+ local linux_config
+ use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+
+ export ac_cv_lib_unwind_unw_backtrace="$(usex unwind)"
+
+ # Need PYTHON3 variable for bug #860240
+ PYTHON3="${PYTHON}" CONFIG_SHELL="${BROOT}"/bin/bash SHELL="${BROOT}"/bin/bash econf ${linux_config} \
+ --with-rundir=/run/openvswitch \
+ --with-logdir=/var/log/openvswitch \
+ --with-pkidir=/etc/ssl/openvswitch \
+ --with-dbdir=/var/lib/openvswitch \
+ $(use_enable ssl) \
+ $(use_enable !debug ndebug)
+}
+
+src_compile() {
+ default
+
+ use modules && linux-mod-r1_src_compile
+}
+
+src_install() {
+ default
+
+ local SCRIPT
+ if use monitor; then
+ # ovs-bugtool is installed to sbin by the build system, but we
+ # install it to bin below, and these clash in merged-usr
+ # https://bugs.gentoo.org/889846
+ rm "${ED}"/usr/sbin/ovs-bugtool || die
+
+ for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
+ python_doscript utilities/"${SCRIPT}"
+ done
+ rm -r "${ED}"/usr/share/openvswitch/python || die
+ fi
+
+ keepdir /var/{lib,log}/openvswitch
+ keepdir /etc/ssl/openvswitch
+ fperms 0750 /etc/ssl/openvswitch
+
+ rm -rf "${ED}"/var/run || die
+
+ newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
+ newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
+ newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
+ newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
+
+ systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
+ systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
+ systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
+ newtmpfiles "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
+
+ insinto /etc/logrotate.d
+ newins rhel/etc_logrotate.d_openvswitch openvswitch
+
+ use modules && linux-mod-r1_src_install
+}
+
+pkg_postinst() {
+ use modules && linux-mod-r1_pkg_postinst
+
+ tmpfiles_process openvswitch.conf
+
+ # Only needed on non-systemd, but helps anyway
+ elog "Use the following command to create an initial database for ovsdb-server:"
+ elog " emerge --config =${CATEGORY}/${PF}"
+ elog "(will create a database in /var/lib/openvswitch/conf.db)"
+ elog "or to convert the database to the current schema after upgrading."
+}
+
+pkg_config() {
+ local db="${EROOT%}"/var/lib/openvswitch/conf.db
+ if [[ -e "${db}" ]] ; then
+ einfo "Database '${db}' already exists, doing schema migration..."
+ einfo "(if the migration fails, make sure that ovsdb-server is not running)"
+ ovsdb-tool convert "${db}" \
+ "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
+ else
+ einfo "Creating new database '${db}'..."
+ ovsdb-tool create "${db}" \
+ "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
+ fi
+}