summaryrefslogtreecommitdiff
path: root/sci-libs/libcifpp/libcifpp-5.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libcifpp/libcifpp-5.0.8.ebuild')
-rw-r--r--sci-libs/libcifpp/libcifpp-5.0.8.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/libcifpp/libcifpp-5.0.8.ebuild b/sci-libs/libcifpp/libcifpp-5.0.8.ebuild
new file mode 100644
index 000000000000..856007e7bd81
--- /dev/null
+++ b/sci-libs/libcifpp/libcifpp-5.0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Code to work with mmCIF and PDB files"
+HOMEPAGE="https://github.com/PDB-REDO/libcifpp"
+# Update components file on every bump
+# ftp://ftp.wwpdb.org/pub/pdb/data/monomers/components.cif.gz
+SRC_URI="
+ https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~pacho/${PN}/${P}-components.cif.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cp "${WORKDIR}"/${P}-components.cif data/components.cif || die
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DCIFPP_DOWNLOAD_CCD=OFF
+ -DCIFPP_INSTALL_UPDATE_SCRIPT=OFF
+ -DENABLE_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}