summaryrefslogtreecommitdiff
path: root/sci-mathematics/arb
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/arb')
-rw-r--r--sci-mathematics/arb/Manifest4
-rw-r--r--sci-mathematics/arb/arb-2.18.0.ebuild37
-rw-r--r--sci-mathematics/arb/files/arb-2.18.0-build_type.patch21
-rw-r--r--sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch20
4 files changed, 82 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index 2634c88d00c1..b0c9fc266e3e 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1,3 +1,7 @@
+AUX arb-2.18.0-build_type.patch 866 BLAKE2B c127152e03d8dd532558a7dc95e4dd2cc1079073d8c30095feea6fa11a65ced564b94dbe3f2c3295fe47a010982a95b2e4408101ad078017d296f9c796f33ddd SHA512 b38728b103b55b19da1f92f9db8bfae74f275d54f83f3409e18503f199467e48fb74bdfb3716c28c01201dd19e8d78d20036671f99cdb63738f33416dc8eb7a2
+AUX arb-2.18.0-multilib-strict.patch 590 BLAKE2B 7f438139ff5f0a19db074ea3bfab064da968424520bc81af242b58675657a7cacce0921076cb5525e00e2d6c33f2b75ed898ffdba7ce730855b09f2b7f8863a1 SHA512 ec9de9a642dd4cb859460132ed597474df4eb2b3f28cdf3ebcb5109fedc2866eda91b0d301149d94f71dd67c105a1dda3d0aed94dcfe34c9ff9fc4083ee6817c
DIST arb-2.17.0.tar.gz 1589083 BLAKE2B 68d5b04dca24129ceaec4e05124e35b474157cf1efbb6505121a03058e014cd4eb67b99497dbbafcf62e9e31f9d11c92f749f6e047e6b1513b6c0cc5ef8f22da SHA512 201e0cebbd1c4857d194e5531c76c6e45a478cf6965b836818919adf0fc04f0fe25e16ecd49c62a438876b67f009b872c4f3c774fe35620be0b22c5e08bdb824
+DIST arb-2.18.0.tar.gz 1595610 BLAKE2B be6a7e1a306f91b70383110e1ef6ead1ebd39f7d408c7a2e3031ca4b6fd788133607779d8f8edb3de1f00abe8ac5f21e07f951caecb4d56ada0517af71265d05 SHA512 3db0b2af4fe63fbc505d9b0e1940165f8bb62eec99d83569a1d959144f33b99141afd6c402d10b24407f9fce1853017a4802850f57fca181cf2f58605395fc31
EBUILD arb-2.17.0.ebuild 2035 BLAKE2B 1866ef62a25faaa1dbfe24423c0cc135b61c7297c18d8ac38aa58f30f26a692cf32e1bd63153dfda66f3be27b39eb1186c684b86d7b9e9ca4d8d1c20be03c764 SHA512 a364ab870eda7e5cdedad53d80be7ad80cfeaeea93935b3637bba6d81fb59bd55c2960a3e605a0d58bb8a7e262357ab8825a60acf1bd8c1a56536431a74c5a7c
+EBUILD arb-2.18.0.ebuild 790 BLAKE2B 5e2101ab5002f49381de85535de0b1449909d11e27c2bde71280839e9b9c6f927ef5feb4401ca9de8e98f8e4d11a09ecb8e292b0055e5b10f326cc27abeb44b7 SHA512 6792a29a1b0b7aae2fc83f8bf666ebc82c770a9e0ab029fc2dc9543ed71f2cdf9cb951afd931e67707ec52c17602b9b21dbd71b0c0f4462fa5751882a9d28ff7
MISC metadata.xml 1077 BLAKE2B d21ef7ffc1b41b7b52d7d8caf246b0109be10d06b7bb4d660c9ae0f750d748cac37cd289df3282cbca9f2658e8fb5f6674c170ea6bfd511edb71a3f0da88bc86 SHA512 cc6a2aed7acd718af2aa1612b1b454a2e699da97a33cb9ba9ca747e3782d9439bb0ff96c25e9023776777a5ee20d2c208c7f98dc73c787a16bfca58e9a10e1ee
diff --git a/sci-mathematics/arb/arb-2.18.0.ebuild b/sci-mathematics/arb/arb-2.18.0.ebuild
new file mode 100644
index 000000000000..691185c1d346
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.18.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.5.0:="
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.18.0-multilib-strict.patch
+ "${FILESDIR}"/${PN}-2.18.0-build_type.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/sci-mathematics/arb/files/arb-2.18.0-build_type.patch b/sci-mathematics/arb/files/arb-2.18.0-build_type.patch
new file mode 100644
index 000000000000..1db7d5f2df42
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.18.0-build_type.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ec806fe..4101c09 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -19,11 +19,11 @@ endif ()
+ set (BUILD_SHARED_LIBS yes CACHE BOOL "Build shared library or not")
+ set (BUILD_TESTING no CACHE BOOL "Build tests or not")
+
+-if (NOT (CMAKE_BUILD_TYPE STREQUAL "Debug" OR
+- CMAKE_BUILD_TYPE STREQUAL "Release"))
+- message("${CMAKE_BUILD_TYPE}")
+- message(FATAL_ERROR "CMAKE_BUILD_TYPE must be one of: Debug, Release (current value: '${CMAKE_BUILD_TYPE}')")
+-endif ()
++# if (NOT (CMAKE_BUILD_TYPE STREQUAL "Debug" OR
++# CMAKE_BUILD_TYPE STREQUAL "Release"))
++# message("${CMAKE_BUILD_TYPE}")
++# message(FATAL_ERROR "CMAKE_BUILD_TYPE must be one of: Debug, Release (current value: '${CMAKE_BUILD_TYPE}')")
++# endif ()
+
+ if ("${CMAKE_SIZEOF_VOID_P}" STREQUAL "8")
+ set (PLATFORM "x64")
diff --git a/sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch b/sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch
new file mode 100644
index 000000000000..e45dec9f3742
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.18.0-multilib-strict.patch
@@ -0,0 +1,20 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ec806fe..d6136a8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -136,10 +136,12 @@ if(NOT MSVC)
+ target_link_libraries(arb m)
+ endif()
+
++include(GNUInstallDirs)
++
+ install(TARGETS arb
+- RUNTIME DESTINATION bin
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ RUNTIME DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}"
++ ARCHIVE DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}"
++ LIBRARY DESTINATION "${CMAKE_INSTALL_FULL_LIBDIR}"
+ )
+
+ foreach (FOLDER ${FOLDERS})