summaryrefslogtreecommitdiff
path: root/sci-physics/root/files/root-6.13.02-hsimple.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root/files/root-6.13.02-hsimple.patch')
-rw-r--r--sci-physics/root/files/root-6.13.02-hsimple.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-physics/root/files/root-6.13.02-hsimple.patch b/sci-physics/root/files/root-6.13.02-hsimple.patch
new file mode 100644
index 000000000000..cab8a40afa7a
--- /dev/null
+++ b/sci-physics/root/files/root-6.13.02-hsimple.patch
@@ -0,0 +1,31 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 03af62fcd3..8ec5330773 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -367,26 +367,6 @@ else()
+ install(DIRECTORY ${CMAKE_BINARY_DIR}/etc/dictpch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
+ endif()
+
+-#---hsimple.root---------(use the executable for clearer dependencies and proper return code)---
+-add_custom_target(hsimple ALL DEPENDS tutorials/hsimple.root)
+-add_dependencies(hsimple onepcm)
+-if(WIN32)
+- add_custom_command(OUTPUT tutorials/hsimple.root
+- COMMAND set PATH=${CMAKE_RUNTIME_OUTPUT_DIRECTORY} &&
+- set ROOTIGNOREPREFIX=1 &&
+- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
+- WORKING_DIRECTORY tutorials
+- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
+-else()
+- add_custom_command(OUTPUT tutorials/hsimple.root
+- COMMAND ${ld_library_path}=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}:$ENV{${ld_library_path}}
+- ROOTIGNOREPREFIX=1
+- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
+- WORKING_DIRECTORY tutorials
+- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
+-endif()
+-install(FILES ${CMAKE_BINARY_DIR}/tutorials/hsimple.root DESTINATION ${CMAKE_INSTALL_TUTDIR} COMPONENT tests)
+-
+ #---version--------------------------------------------------------------------------------------
+ if(NOT WIN32)
+ add_custom_target(version COMMAND ${CMAKE_SOURCE_DIR}/build/unix/makeversion.sh ${CMAKE_BINARY_DIR}