summaryrefslogtreecommitdiff
path: root/sys-cluster/hubble
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hubble')
-rw-r--r--sys-cluster/hubble/Manifest3
-rw-r--r--sys-cluster/hubble/hubble-0.10.0.ebuild27
-rw-r--r--sys-cluster/hubble/metadata.xml8
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-cluster/hubble/Manifest b/sys-cluster/hubble/Manifest
new file mode 100644
index 000000000000..f8384d11a9f5
--- /dev/null
+++ b/sys-cluster/hubble/Manifest
@@ -0,0 +1,3 @@
+DIST hubble-0.10.0.tar.gz 6453598 BLAKE2B e3b91e4aa3fd7de6cc474a7f99e37cbde542ae66d3dc2e509cc9db36e3d0e127803fb84b972c017cafa598663f5d845832c246b4fc99420dade4f61e94ad4e2f SHA512 d8f6347954a7fc4ff2a707c7a21e699c562647c9d4eea238345db9c93fdf232cf52482c8f79046bdee1fff8d34839eaf4b80de6877b18d45cec77a8190ef7f58
+EBUILD hubble-0.10.0.ebuild 536 BLAKE2B 09403e2ae94c1499d5248314ad9edfae776a2cb3bcb462e1861501335792f3c13615b0b22d46e4fbba171a1c70989ad938c8d750fe5be0393f6dd4b4ea5a804a SHA512 65e03696502b32de986a665817f2c5c40599bb189305f2fdbda35ede2aa77bd0299ce2626b4759c8c2cc0292d1bb988d1e57ae31e156d25284694770cfdf9eac
+MISC metadata.xml 249 BLAKE2B 08603bf9d754b59bae12620988552abc7f76b87a1390d02038789eba034c22412a3593d10f443794a5171ff3905c2b5c822368b2eb9f53a528097b7b6c80ffe9 SHA512 338d72efbd040697be98aad4229b81c9694eb27ecbc39f3a18332f4cc766a46b4a0a92f32612203259bf58f5838d0aff7f0b1abec7766f6cd2394c73f7f0b251
diff --git a/sys-cluster/hubble/hubble-0.10.0.ebuild b/sys-cluster/hubble/hubble-0.10.0.ebuild
new file mode 100644
index 000000000000..c9c9ba326b12
--- /dev/null
+++ b/sys-cluster/hubble/hubble-0.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# make sure this gets updated on every bump
+GIT_HASH=daec1c89
+
+DESCRIPTION="Network, Service & Security Observability for Kubernetes using eBPF"
+HOMEPAGE="https://cilium.io"
+SRC_URI="https://github.com/cilium/hubble/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake GIT_HASH=${GIT_HASH}
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin hubble
+}
diff --git a/sys-cluster/hubble/metadata.xml b/sys-cluster/hubble/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/sys-cluster/hubble/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>