summaryrefslogtreecommitdiff
path: root/sys-devel/clang/clang-16.0.0_pre20230107.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-16.0.0_pre20230107.ebuild')
-rw-r--r--sys-devel/clang/clang-16.0.0_pre20230107.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/clang/clang-16.0.0_pre20230107.ebuild b/sys-devel/clang/clang-16.0.0_pre20230107.ebuild
index 34eba8f9bc95..b3eeacb43e1d 100644
--- a/sys-devel/clang/clang-16.0.0_pre20230107.ebuild
+++ b/sys-devel/clang/clang-16.0.0_pre20230107.ebuild
@@ -331,8 +331,10 @@ multilib_src_configure() {
if tc-is-cross-compiler; then
has_version -b sys-devel/clang:${LLVM_MAJOR} ||
die "sys-devel/clang:${LLVM_MAJOR} is required on the build host."
+ local tools_bin=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/bin
mycmakeargs+=(
- -DLLVM_TOOLS_BINARY_DIR="${BROOT}"/usr/lib/llvm/${LLVM_MAJOR}/bin
+ -DLLVM_TOOLS_BINARY_DIR="${tools_bin}"
+ -DCLANG_TABLEGEN="${tools_bin}"/clang-tblgen
)
fi