summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-11.2.1_p20211127.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-11.2.1_p20211127.ebuild')
-rw-r--r--sys-devel/gcc/gcc-11.2.1_p20211127.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-11.2.1_p20211127.ebuild b/sys-devel/gcc/gcc-11.2.1_p20211127.ebuild
new file mode 100644
index 000000000000..808255171410
--- /dev/null
+++ b/sys-devel/gcc/gcc-11.2.1_p20211127.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PATCH_VER="0"
+PATCH_GCC_VER="11.3.0"
+MUSL_VER="1"
+MUSL_GCC_VER="11.2.0"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ if tc-is-cross-compiler ; then
+ # bug #803371
+ eapply "${FILESDIR}"/gcc-11.2.0-cross-compile-include.patch
+ fi
+
+ eapply_user
+}