summaryrefslogtreecommitdiff
path: root/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild')
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild
deleted file mode 100644
index 833ce1b77e81..000000000000
--- a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use LLD on binutils-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="multilib-symlinks +native-symlinks"
-
-RDEPEND="
- sys-devel/lld:${SLOT}
-"
-
-src_install() {
- use native-symlinks || return
-
- local chosts=( "${CHOST}" )
- if use multilib-symlinks; then
- local abi
- for abi in $(get_all_abis); do
- chosts+=( "$(get_abi_CHOST "${abi}")" )
- done
- fi
-
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- dosym ld.lld "${dest}/ld"
- for chost in "${chosts[@]}"; do
- dosym ld.lld "${dest}/${chost}-ld"
- done
-}