summaryrefslogtreecommitdiff
path: root/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16.ebuild')
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16.ebuild
deleted file mode 100644
index aefb59aafa0d..000000000000
--- a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-16.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib
-
-DESCRIPTION="Symlinks to use LLD on binutils-free system"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
-SRC_URI=""
-S=${WORKDIR}
-
-LICENSE="public-domain"
-SLOT="${PV}"
-KEYWORDS=""
-PROPERTIES="live"
-IUSE="+native-symlinks"
-
-RDEPEND="
- sys-devel/lld
-"
-
-src_install() {
- use native-symlinks || return
-
- local abi
- local dest=/usr/lib/llvm/${SLOT}/bin
- dodir "${dest}"
- dosym ../../../../bin/ld.lld "${dest}/ld"
- for abi in $(get_all_abis); do
- local abi_chost=$(get_abi_CHOST "${abi}")
- dosym ../../../../bin/ld.lld "${dest}/${abi_chost}-ld"
- done
-}