summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-6.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-6.0.1-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-6.0.1-r2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-6.0.1-r2.ebuild b/sys-devel/llvm/llvm-6.0.1-r2.ebuild
index 7a983e01f194..f9c0b897dbe3 100644
--- a/sys-devel/llvm/llvm-6.0.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-6.0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,14 +32,19 @@ ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LICENSE="UoI-NCSA rc BSD public-domain
llvm_targets_ARM? ( LLVM-Grant )"
SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug doc gold libedit +libffi ncurses test xar xml
kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
RESTRICT="!test? ( test )"
RDEPEND="
sys-libs/zlib:0=
- gold? ( >=sys-devel/binutils-2.22:*[cxx] )
+ gold? (
+ || (
+ >=sys-devel/binutils-2.31.1-r4:*[plugins]
+ <sys-devel/binutils-2.31.1-r4:*[cxx]
+ )
+ )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )