summaryrefslogtreecommitdiff
path: root/sys-fs/ubi_reader/ubi_reader-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ubi_reader/ubi_reader-0.8.0.ebuild')
-rw-r--r--sys-fs/ubi_reader/ubi_reader-0.8.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-fs/ubi_reader/ubi_reader-0.8.0.ebuild b/sys-fs/ubi_reader/ubi_reader-0.8.0.ebuild
new file mode 100644
index 000000000000..88f0ab7805aa
--- /dev/null
+++ b/sys-fs/ubi_reader/ubi_reader-0.8.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN/_/-}"
+DESCRIPTION="Collection of Python scripts for extracting data from UBI and UBIFS images"
+HOMEPAGE="https://github.com/jrspruitt/ubi_reader"
+SRC_URI="https://github.com/jrspruitt/ubi_reader/archive/refs/tags/v${PV}-master.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}-master"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-lzo[${PYTHON_USEDEP}]"