summaryrefslogtreecommitdiff
path: root/sys-process/pkill-darwin
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/pkill-darwin')
-rw-r--r--sys-process/pkill-darwin/Manifest2
-rw-r--r--sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild (renamed from sys-process/pkill-darwin/pkill-darwin-1.0.ebuild)12
2 files changed, 6 insertions, 8 deletions
diff --git a/sys-process/pkill-darwin/Manifest b/sys-process/pkill-darwin/Manifest
index 7a0d4b1aa6c3..a0ddc715c614 100644
--- a/sys-process/pkill-darwin/Manifest
+++ b/sys-process/pkill-darwin/Manifest
@@ -1,3 +1,3 @@
DIST pkill-darwin-1.0.tar.xz 8232 BLAKE2B 283c49e125d55de6994013ca002225ddc728fc837029fafbddf4d9c4e0574761a220cc347f62d95b49d4e430b4d53c20a712e73b497700272c7f022a913e0f16 SHA512 18ced350664b6dcd07acb33e1872726857a6f762311f91ca2d30323153712a436017b232efd34f8cd0055e10f1036d4a84a06f37ef104722701a172a40d3575a
-EBUILD pkill-darwin-1.0.ebuild 1084 BLAKE2B ee26095ddb577de6e986c9e3c8f9db8991375770d8cc32c68b7d6d46f7c86208907c83ef78fc88988dfb4071473f9d7606441d0ac7009340fff7988dda0df8c5 SHA512 2d11620eeb92fea6bbff87353ed6c0fe8ea0e8a66af283d29966e98f7423024aff5b05e7eafdc8e8fe1d75e6b352f680c3ae6cc8aa46610e84dd6615d5875388
+EBUILD pkill-darwin-1.0-r1.ebuild 1021 BLAKE2B 8021e91cede61a005e3036ecb6bf3e40d627ec304b1812e8795d203cdb1499df4e3a1373a02962d7a2691e90685db1ea49fe297ecd3727b2c03904dec4ea773f SHA512 c96767d496c4ad22723dc90eaeb867347a0e7d550720e9cf92f709c417938276788847473c26a4b5eca50fee0731a52a3439319595f33e30e9c30f534742d49d
MISC metadata.xml 254 BLAKE2B a9286f3fc430caa6275f03922e751f715f0f40b280a287b94b223dc132ded7e0d52a9e9b7d60ec49e51241816f2e902555f0225cd989a24274c6c1308fc3b069 SHA512 87bf08a79b46585f8b0a0ec3b465e6e9442fde5d4dc94dcc39e7ad74749b2e3cfd3411226dd9cf209e96cbedf3e3e704aa966a0ca8ad1505412eb70d00baa2f2
diff --git a/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild b/sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild
index 4cf240fc54b6..6adbd78f04cb 100644
--- a/sys-process/pkill-darwin/pkill-darwin-1.0.ebuild
+++ b/sys-process/pkill-darwin/pkill-darwin-1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit toolchain-funcs
+inherit edo toolchain-funcs
DESCRIPTION="pgrep(1) and pkill(1) for Darwin"
HOMEPAGE="https://sourceforge.net/p/pkilldarwin/code/ci/default/tree/"
@@ -12,11 +12,9 @@ SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~arm64-macos ~ppc-macos ~x64-macos"
-IUSE=""
src_compile() {
- echo $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c
- $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c || die
+ edo $(tc-getCC) ${CFLAGS} -o pkill ${LDFLAGS} pkill.c
# don't link, such that the suid trick described below won't make people
# suid their pkill too
cp pkill pgrep || die
@@ -34,5 +32,5 @@ pkg_postinst() {
einfo "of all processes, you will have to make pgrep suid root. To do so"
einfo "you have to perform the following steps:"
einfo " % sudo chown root ${EPREFIX}/usr/bin/pgrep"
- einfo " % sudo chmod u+s ${EPREFIX}/usr/bin/prgep"
+ einfo " % sudo chmod u+s ${EPREFIX}/usr/bin/pgrep"
}