summaryrefslogtreecommitdiff
path: root/www-apps/novnc/novnc-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/novnc/novnc-1.2.0.ebuild')
-rw-r--r--www-apps/novnc/novnc-1.2.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/www-apps/novnc/novnc-1.2.0.ebuild b/www-apps/novnc/novnc-1.2.0.ebuild
index d055a2d70452..02803bff38ac 100644
--- a/www-apps/novnc/novnc-1.2.0.ebuild
+++ b/www-apps/novnc/novnc-1.2.0.ebuild
@@ -3,14 +3,13 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
HOMEPAGE="https://kanaka.github.com/noVNC/"
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
else
@@ -21,10 +20,8 @@ fi
LICENSE="LGPL-3"
SLOT="0"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
+RDEPEND="
dev-python/websockify[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]"