summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-120.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-120.0.ebuild')
-rw-r--r--www-client/firefox/firefox-120.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-120.0.ebuild b/www-client/firefox/firefox-120.0.ebuild
index cd20a5293678..fa5d4105f8f4 100644
--- a/www-client/firefox/firefox-120.0.ebuild
+++ b/www-client/firefox/firefox-120.0.ebuild
@@ -660,12 +660,13 @@ src_prepare() {
rm -v "${WORKDIR}"/firefox-patches/*ppc64*.patch || die
fi
- eapply "${WORKDIR}/firefox-patches"
-
# Workaround for bgo#917599
- if use system-icu && ! has_version ">=dev-libs/icu-74.1" ; then
- rm -v "${WORKDIR}"/firefox-patches/0028-bmo-1862601-system-icu-74.patch || die
+ if has_version ">=dev-libs/icu-74.1" && use system-icu ; then
+ eapply "${WORKDIR}"/firefox-patches/0028-bmo-1862601-system-icu-74.patch
fi
+ rm -v "${WORKDIR}"/firefox-patches/0028-bmo-1862601-system-icu-74.patch || die
+
+ eapply "${WORKDIR}/firefox-patches"
# Allow user to apply any additional patches without modifing ebuild
eapply_user