summaryrefslogtreecommitdiff
path: root/www-client/qutebrowser/qutebrowser-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qutebrowser/qutebrowser-9999.ebuild')
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 0521c244a164..c4bb985b2edc 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -74,7 +74,13 @@ src_prepare() {
# let eclass handle python
sed -i '/setup.py/d' misc/Makefile || die
- [[ ${PV} != 9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
+ if [[ ${PV} == 9999 ]]; then
+ # call asciidoc(1) rather than the single target python module
+ sed '/cmdline = /s/= .*/= ["asciidoc"]/' \
+ -i scripts/asciidoc2html.py || die
+
+ "${EPYTHON}" scripts/asciidoc2html.py || die
+ fi
# these plugins/tests are unnecessary here and have extra dependencies
sed -e '/pytest-benchmark/d;s/--benchmark[^ ]*//' \