summaryrefslogtreecommitdiff
path: root/www-plugins/browserpass/browserpass-3.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/browserpass/browserpass-3.0.9.ebuild')
-rw-r--r--www-plugins/browserpass/browserpass-3.0.9.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-plugins/browserpass/browserpass-3.0.9.ebuild b/www-plugins/browserpass/browserpass-3.0.9.ebuild
new file mode 100644
index 000000000000..176909893672
--- /dev/null
+++ b/www-plugins/browserpass/browserpass-3.0.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+MY_PN=browserpass-native
+
+DESCRIPTION="WebExtension host binary for app-admin/pass, a UNIX password manager"
+HOMEPAGE="https://github.com/browserpass/browserpass-native"
+
+go-module_set_globals
+SRC_URI="https://github.com/browserpass/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="BSD ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="app-crypt/gnupg"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_compile() {
+ ego build || die
+
+ sed -e 's|%%replace%%|'${EPREFIX}'/usr/libexec/browserpass-native|' \
+ -i browser-files/firefox-host.json browser-files/chromium-host.json || die
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe browserpass-native
+
+ insinto /usr/lib/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /usr/lib64/mozilla/native-messaging-hosts
+ newins browser-files/firefox-host.json com.github.browserpass.native.json
+
+ insinto /etc/chromium/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+
+ insinto /etc/opt/chrome/native-messaging-hosts
+ newins browser-files/chromium-host.json com.github.browserpass.native.json
+}